summaryrefslogtreecommitdiff
path: root/sql/share/Makefile.am
diff options
context:
space:
mode:
authorunknown <jcole@ham.spaceapes.com>2000-09-14 00:33:16 +0000
committerunknown <jcole@ham.spaceapes.com>2000-09-14 00:33:16 +0000
commit35a6dc53af5dee4afc1a54c37e3977909a2e655b (patch)
tree75dd17c2415042560f80e5c1802d61d0857cc3ee /sql/share/Makefile.am
parent462f6c94378c16b708b665663942ae91f6ef3923 (diff)
downloadmariadb-git-35a6dc53af5dee4afc1a54c37e3977909a2e655b.tar.gz
Fixed a problem with installing, for IRIX 'install', paths would
be wrong and install would fail. sql/share/Makefile.am: When installing, should cd into the directory where the files are coming from. This caused a problem with one of our customers using an SGI IRIX machine, I'd guess that IRIX uses some version of install that doesn't disregard the path of the source file when copying the files.
Diffstat (limited to 'sql/share/Makefile.am')
-rw-r--r--sql/share/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/sql/share/Makefile.am b/sql/share/Makefile.am
index 9b0f0a2991f..6080899c33e 100644
--- a/sql/share/Makefile.am
+++ b/sql/share/Makefile.am
@@ -16,7 +16,7 @@ install-data-local:
$(DESTDIR)$(pkgdatadir)/$$lang/errmsg.txt; \
done
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/charsets
- (for f in Index README "*.conf"; \
+ (cd $(srcdir)/charsets; for f in Index README "*.conf"; \
do \
- $(INSTALL_DATA) $(srcdir)/charsets/$$f $(DESTDIR)$(pkgdatadir)/charsets/; \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgdatadir)/charsets/; \
done)