summaryrefslogtreecommitdiff
path: root/storage/blackhole/Makefile.am
diff options
context:
space:
mode:
authorunknown <tsmith@rhel5-ia64-a.mysql.com>2008-03-27 08:20:25 +0100
committerunknown <tsmith@rhel5-ia64-a.mysql.com>2008-03-27 08:20:25 +0100
commit45ebe9953385f48f99058eaedf448bb6ff8caeaa (patch)
tree1cd9471bfb066e2ed5fdc557a5948b95230098ec /storage/blackhole/Makefile.am
parent27c0540bd8e785499accbd4777bdb5067911cce9 (diff)
parent19afc9d9e75b44c01e254300913b716798c40108 (diff)
downloadmariadb-git-45ebe9953385f48f99058eaedf448bb6ff8caeaa.tar.gz
Merge tsmith@bk-internal.mysql.com:/home/bk/mysql-5.1
into rhel5-ia64-a.mysql.com:/data0/tsmith/build/51 sql/mysqld.cc: Auto merged sql/sql_acl.cc: Auto merged sql/sql_class.cc: Auto merged mysql-test/r/drop.result: SCCS merged mysql-test/t/drop.test: SCCS merged
Diffstat (limited to 'storage/blackhole/Makefile.am')
-rw-r--r--storage/blackhole/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/storage/blackhole/Makefile.am b/storage/blackhole/Makefile.am
index 9dd533dd4fa..db4f67cf847 100644
--- a/storage/blackhole/Makefile.am
+++ b/storage/blackhole/Makefile.am
@@ -19,6 +19,7 @@ MYSQLDATAdir = $(localstatedir)
MYSQLSHAREdir = $(pkgdatadir)
MYSQLBASEdir= $(prefix)
MYSQLLIBdir= $(pkglibdir)
+pkgplugindir = $(pkglibdir)/plugin
INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include \
-I$(top_srcdir)/regex \
-I$(top_srcdir)/sql \
@@ -32,8 +33,8 @@ DEFS = @DEFS@
noinst_HEADERS = ha_blackhole.h
EXTRA_LTLIBRARIES = ha_blackhole.la
-pkglib_LTLIBRARIES = @plugin_blackhole_shared_target@
-ha_blackhole_la_LDFLAGS=-module -rpath $(MYSQLLIBdir)
+pkgplugin_LTLIBRARIES = @plugin_blackhole_shared_target@
+ha_blackhole_la_LDFLAGS=-module -rpath $(pkgplugindir)
ha_blackhole_la_CXXFLAGS=$(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
ha_blackhole_la_CFLAGS= $(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
ha_blackhole_la_SOURCES=ha_blackhole.cc