summaryrefslogtreecommitdiff
path: root/storage/example/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2009-12-01 12:00:50 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2009-12-01 12:00:50 +0100
commitd2139f313583aa7f6e09a505ea44aff0073d0d0d (patch)
treed89705a5ecb9443a34d6ac498e2557565ff952b2 /storage/example/CMakeLists.txt
parent43770e8f3f3fd22259b330756fad72737b079263 (diff)
downloadmariadb-git-d2139f313583aa7f6e09a505ea44aff0073d0d0d.tar.gz
- Introduce MYSQL_ADD_PLUGIN that replaces MYSQL_STORAGE_ENGINE
- Fix semisync library prefix (remove lib on Unixes) - restrict exported symbols from zlib and yassl (fvisibility=hidden)
Diffstat (limited to 'storage/example/CMakeLists.txt')
-rw-r--r--storage/example/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/storage/example/CMakeLists.txt b/storage/example/CMakeLists.txt
index 47722dfd53b..109f4bfa844 100644
--- a/storage/example/CMakeLists.txt
+++ b/storage/example/CMakeLists.txt
@@ -15,4 +15,4 @@
SET(EXAMPLE_PLUGIN_DYNAMIC "ha_example")
SET(EXAMPLE_SOURCES ha_example.cc)
-MYSQL_STORAGE_ENGINE(EXAMPLE)
+MYSQL_ADD_PLUGIN(example ${EXAMPLE_SOURCES} STORAGE_ENGINE)