summaryrefslogtreecommitdiff
path: root/storage/heap/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2006-08-19 08:02:52 -0700
committerunknown <brian@zim.(none)>2006-08-19 08:02:52 -0700
commit39f1d9f411160beb20f367fec4d01f9721d7a513 (patch)
treebff4aef57437dbbbcad1f67836d2d87629079ee4 /storage/heap/Makefile.am
parentb470b3ab87743a13470098b8446da3fe2e100c9e (diff)
downloadmariadb-git-39f1d9f411160beb20f367fec4d01f9721d7a513.tar.gz
Moved heap into its own directory.
storage/heap/ha_heap.h: Rename: sql/ha_heap.h -> storage/heap/ha_heap.h libmysqld/Makefile.am: Heap changes sql/CMakeLists.txt: Removed ha_heap sql/Makefile.am: Removed heap sql/handler.cc: Removed unneeded include call storage/heap/Makefile.am: Adjusted heap Makefile.am to include ha_heap.cc storage/heap/ha_heap.cc: Added plugin header
Diffstat (limited to 'storage/heap/Makefile.am')
-rw-r--r--storage/heap/Makefile.am30
1 files changed, 24 insertions, 6 deletions
diff --git a/storage/heap/Makefile.am b/storage/heap/Makefile.am
index 68dce9bca5f..e8cbaa285ef 100644
--- a/storage/heap/Makefile.am
+++ b/storage/heap/Makefile.am
@@ -14,21 +14,39 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
-LDADD = libheap.a \
- $(top_builddir)/mysys/libmysys.a \
- $(top_builddir)/dbug/libdbug.a \
- $(top_builddir)/strings/libmystrings.a
+MYSQLDATAdir = $(localstatedir)
+MYSQLSHAREdir = $(pkgdatadir)
+MYSQLBASEdir= $(prefix)
+MYSQLLIBdir= $(pkglibdir)
+INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include \
+ -I$(top_srcdir)/regex \
+ -I$(top_srcdir)/sql \
+ -I$(srcdir)
+WRAPLIBS=
+
+LDADD =
+
+DEFS = @DEFS@
pkglib_LIBRARIES = libheap.a
noinst_PROGRAMS = hp_test1 hp_test2
+noinst_LIBRARIES = libheap.a
hp_test1_LDFLAGS = @NOINST_LDFLAGS@
+hp_test1_LDADD = libheap.a \
+ $(top_builddir)/mysys/libmysys.a \
+ $(top_builddir)/dbug/libdbug.a \
+ $(top_builddir)/strings/libmystrings.a
hp_test2_LDFLAGS = @NOINST_LDFLAGS@
-noinst_HEADERS = heapdef.h
+hp_test2_LDADD = libheap.a \
+ $(top_builddir)/mysys/libmysys.a \
+ $(top_builddir)/dbug/libdbug.a \
+ $(top_builddir)/strings/libmystrings.a
+noinst_HEADERS = heapdef.h ha_heap.h
libheap_a_SOURCES = hp_open.c hp_extra.c hp_close.c hp_panic.c hp_info.c \
hp_rrnd.c hp_scan.c hp_update.c hp_write.c hp_delete.c \
hp_rsame.c hp_create.c hp_rename.c hp_rfirst.c \
hp_rnext.c hp_rlast.c hp_rprev.c hp_clear.c \
hp_rkey.c hp_block.c \
+ ha_heap.cc \
hp_hash.c _check.c _rectest.c hp_static.c
EXTRA_DIST = CMakeLists.txt