summaryrefslogtreecommitdiff
path: root/storage/maria/Makefile.am
diff options
context:
space:
mode:
authorunknown <bell@desktop.sanja.is.com.ua>2008-01-12 18:25:20 +0200
committerunknown <bell@desktop.sanja.is.com.ua>2008-01-12 18:25:20 +0200
commit83b6f69602e04cace24a37b07c77348553de8baa (patch)
tree2dc76faff5742fda78d275ea49eb3c30a66a1c1f /storage/maria/Makefile.am
parent0cccfe30cc5ba9e6b02b90eeec73753b5136f892 (diff)
downloadmariadb-git-83b6f69602e04cace24a37b07c77348553de8baa.tar.gz
maria_dump_log - log interpreter added.
storage/maria/Makefile.am: maria_dump_log build. storage/maria/ma_loghandler.c: Fixed page size in the log header to be independent of #defines. maria_dump_log - log interpreter added.
Diffstat (limited to 'storage/maria/Makefile.am')
-rw-r--r--storage/maria/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/storage/maria/Makefile.am b/storage/maria/Makefile.am
index d1932746c82..74911fcd417 100644
--- a/storage/maria/Makefile.am
+++ b/storage/maria/Makefile.am
@@ -34,7 +34,8 @@ EXTRA_DIST = ma_test_all.sh ma_test_all.res ma_test_big.sh \
ma_ft_stem.c CMakeLists.txt plug.in ma_test_recovery
pkgdata_DATA = ma_test_all ma_test_all.res ma_test_recovery
pkglib_LIBRARIES = libmaria.a
-bin_PROGRAMS = maria_chk maria_pack maria_ftdump maria_read_log
+bin_PROGRAMS = maria_chk maria_pack maria_ftdump maria_read_log \
+ maria_dump_log
maria_chk_DEPENDENCIES= $(LIBRARIES)
# Only reason to link with libmyisam.a here is that it's where some fulltext
# pieces are (but soon we'll remove fulltext dependencies from Maria).
@@ -56,6 +57,14 @@ maria_read_log_LDADD= @CLIENT_EXTRA_LDFLAGS@ libmaria.a \
$(top_builddir)/mysys/libmysys.a \
$(top_builddir)/dbug/libdbug.a \
$(top_builddir)/strings/libmystrings.a @ZLIB_LIBS@
+maria_dump_log_DEPENDENCIES=$(LIBRARIES) ma_loghandler.c
+maria_dump_log_LDADD= @CLIENT_EXTRA_LDFLAGS@ libmaria.a \
+ $(top_builddir)/storage/myisam/libmyisam.a \
+ $(top_builddir)/mysys/libmysys.a \
+ $(top_builddir)/dbug/libdbug.a \
+ $(top_builddir)/strings/libmystrings.a @ZLIB_LIBS@
+maria_dump_log_SOURCES= ma_loghandler.c
+maria_dump_log_CPPFLAGS= -DMARIA_DUMP_LOG
noinst_PROGRAMS = ma_test1 ma_test2 ma_test3 ma_rt_test ma_sp_test
noinst_HEADERS = maria_def.h ma_rt_index.h ma_rt_key.h ma_rt_mbr.h \
ma_sp_defs.h ma_fulltext.h ma_ftdefs.h ma_ft_test1.h \