summaryrefslogtreecommitdiff
path: root/storage/myisam/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2006-08-22 16:24:12 -0700
committerunknown <brian@zim.(none)>2006-08-22 16:24:12 -0700
commit977cd20a70d0d4ca9058d2b287baf12c64dc19fa (patch)
treed9b86be7b64fbabbe0a221783f850077ca7ce8ad /storage/myisam/Makefile.am
parentcfafd45807807370ae01beadf5ad4a133ef6d402 (diff)
downloadmariadb-git-977cd20a70d0d4ca9058d2b287baf12c64dc19fa.tar.gz
This changest:
Plugins now when compiled or not compiled work correctly with status variables. Status variables from plugins now set their own names (removed bit where plugin name was pre-appended this broke Innodb and Cluster) A few Makefile cleanups. sql/ha_innodb.cc: Cleanup to make status variables directly in engine sql/ha_ndbcluster.cc: Engine interface now has variables for status sql/handler.cc: handler now makes sure to init status variables sql/mysqld.cc: Removed status variable hacks sql/sql_delete.cc: Removed include file that was not required storage/myisam/Makefile.am: Cleaned up line lengths and addded additional include to not install. storage/myisam/ha_myisam.cc: Removed double plugin include
Diffstat (limited to 'storage/myisam/Makefile.am')
-rw-r--r--storage/myisam/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/storage/myisam/Makefile.am b/storage/myisam/Makefile.am
index 644fc900c7f..fdccb1f5b19 100644
--- a/storage/myisam/Makefile.am
+++ b/storage/myisam/Makefile.am
@@ -49,7 +49,9 @@ myisampack_LDADD= @CLIENT_EXTRA_LDFLAGS@ libmyisam.a \
$(top_builddir)/dbug/libdbug.a \
$(top_builddir)/strings/libmystrings.a @ZLIB_LIBS@
noinst_PROGRAMS = mi_test1 mi_test2 mi_test3 rt_test sp_test #ft_test1 ft_eval
-noinst_HEADERS = myisamdef.h rt_index.h rt_key.h rt_mbr.h sp_defs.h fulltext.h ftdefs.h ft_test1.h ft_eval.h
+noinst_HEADERS = myisamdef.h rt_index.h rt_key.h rt_mbr.h sp_defs.h \
+ fulltext.h ftdefs.h ft_test1.h ft_eval.h \
+ ha_myisam.h
mi_test1_DEPENDENCIES= $(LIBRARIES)
mi_test1_LDADD= @CLIENT_EXTRA_LDFLAGS@ libmyisam.a \
$(top_builddir)/mysys/libmysys.a \