summaryrefslogtreecommitdiff
path: root/storage/ndb/src/common/util/Makefile.am
diff options
context:
space:
mode:
authorGeorgi Kodinov <joro@sun.com>2010-03-09 17:51:31 +0200
committerGeorgi Kodinov <joro@sun.com>2010-03-09 17:51:31 +0200
commita774c83c2f6936dbafbe4e1149a2305bb691f040 (patch)
treee0c9c3ec68d50dbe8fd46a608ddb2aaf82867067 /storage/ndb/src/common/util/Makefile.am
parent56f42962ff3d5109f29487572d34892cd8fc7da5 (diff)
downloadmariadb-git-a774c83c2f6936dbafbe4e1149a2305bb691f040.tar.gz
Bug #35250: readline check breaks when doing vpath build
MySQL uses two source layouts when building : the bzr layout and the source package layout. The previous fix for bug 35250 contained 1 change that is valid for both modes and a number of changes that are valid only for the bzr source layout. The important thing was to fix the source package layout. And for this the change in configure.in was sufficient. It's not trivial (and not requested by this bug) to support VPATH builds from the bzr trees. This is why the other changes are reverted and the change to fix the VPATH build for source distributions is left intact.
Diffstat (limited to 'storage/ndb/src/common/util/Makefile.am')
-rw-r--r--storage/ndb/src/common/util/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/storage/ndb/src/common/util/Makefile.am b/storage/ndb/src/common/util/Makefile.am
index 5cf02fed12f..5379a425c49 100644
--- a/storage/ndb/src/common/util/Makefile.am
+++ b/storage/ndb/src/common/util/Makefile.am
@@ -37,7 +37,7 @@ testBitmask_LDFLAGS = @ndb_bin_am_ldflags@ \
testBitmask.cpp : Bitmask.cpp
rm -f testBitmask.cpp
- @LN_CP_F@ $(srcdir)/Bitmask.cpp testBitmask.cpp
+ @LN_CP_F@ Bitmask.cpp testBitmask.cpp
testBitmask.o: $(testBitmask_SOURCES)
$(CXXCOMPILE) -c $(INCLUDES) -D__TEST_BITMASK__ $<