summaryrefslogtreecommitdiff
path: root/storage/oqgraph/CMakeLists.txt
diff options
context:
space:
mode:
authorandrew <andrew@madev.eaglenest>2013-09-06 20:27:33 +0930
committerandrew <andrew@madev.eaglenest>2013-09-06 20:27:33 +0930
commit8824afd1524120ec25b13ffac7e7cb1a5023f4eb (patch)
tree877b7e9de855ed359988ea2db3e2b9a75b0c3bfe /storage/oqgraph/CMakeLists.txt
parent6686a4eb515ff134514c34c131c2992c341a37cc (diff)
downloadmariadb-git-8824afd1524120ec25b13ffac7e7cb1a5023f4eb.tar.gz
Fix for build error on gcc 4.7
Diffstat (limited to 'storage/oqgraph/CMakeLists.txt')
-rw-r--r--storage/oqgraph/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/storage/oqgraph/CMakeLists.txt b/storage/oqgraph/CMakeLists.txt
index 2ef23e1553b..6b7a32cf2f8 100644
--- a/storage/oqgraph/CMakeLists.txt
+++ b/storage/oqgraph/CMakeLists.txt
@@ -47,7 +47,8 @@ IF(BOOST_OK)
IF(MSVC)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /EHsc")
ELSE(MSVC)
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-deprecated -fno-strict-aliasing")
+ # Fix lp bug 1221555 with -fpermissive, so that errors in gcc 4.7 become warnings for the time being
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-deprecated -fno-strict-aliasing -fpermissive")
STRING(REPLACE "-fno-exceptions" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "-fno-implicit-templates" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
ENDIF(MSVC)