summaryrefslogtreecommitdiff
path: root/storage/oqgraph/CMakeLists.txt
diff options
context:
space:
mode:
authorAntony T Curtis <antony@xiphis.org>2012-09-30 14:49:46 -0700
committerAntony T Curtis <antony@xiphis.org>2012-09-30 14:49:46 -0700
commit2847178edd9027698c6a6fc096ba7b0e6165e1b4 (patch)
tree6c06b9ece7919c30b8d1202f4222e1199a02be34 /storage/oqgraph/CMakeLists.txt
parentb965d031bb8fae358c28d7693f16a1f0724afe68 (diff)
downloadmariadb-git-2847178edd9027698c6a6fc096ba7b0e6165e1b4.tar.gz
Post merge fixes
Diffstat (limited to 'storage/oqgraph/CMakeLists.txt')
-rw-r--r--storage/oqgraph/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/storage/oqgraph/CMakeLists.txt b/storage/oqgraph/CMakeLists.txt
index 83acb99b2a2..70660536017 100644
--- a/storage/oqgraph/CMakeLists.txt
+++ b/storage/oqgraph/CMakeLists.txt
@@ -1,9 +1,18 @@
-FIND_PACKAGE(Boost 1.40.0)
+MESSAGE(STATUS "Configuring OQGraph")
+FIND_PACKAGE(Boost)
IF(NOT Boost_FOUND)
+ MESSAGE(STATUS "Boost not found")
RETURN()
ENDIF()
INCLUDE_DIRECTORIES(BEFORE ${Boost_INCLUDE_DIRS})
+FIND_PACKAGE(JUDY)
+IF(NOT JUDY_FOUND)
+ MESSAGE(STATUS "Judy not found")
+ RETURN()
+ENDIF()
+INCLUDE_DIRECTORIES(${JUDY_INCLUDE_DIR})
+
IF(MSVC)
# lp:756966 OQGRAPH on Win64 does not compile
IF (CMAKE_SIZEOF_VOID_P EQUAL 8)
@@ -33,4 +42,6 @@ IF(BOOST_OK)
MYSQL_ADD_PLUGIN(oqgraph ha_oqgraph.cc graphcore.cc STORAGE_ENGINE
MODULE_ONLY)
+ELSE(BOOST_OK)
+ MESSAGE(STATUS "Requisites for OQGraph not met")
ENDIF(BOOST_OK)