summaryrefslogtreecommitdiff
path: root/storage/oqgraph/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <sergii@pisem.net>2012-08-11 10:31:10 +0200
committerSergei Golubchik <sergii@pisem.net>2012-08-11 10:31:10 +0200
commitc9b95de246ccaad22abf90996f295b05fe85f53d (patch)
treeb87d9489437884587a72724ceb08e2f00b526f9e /storage/oqgraph/CMakeLists.txt
parent16c763098ac5d0fd63e1e1b33e5a91ed6172a34d (diff)
downloadmariadb-git-c9b95de246ccaad22abf90996f295b05fe85f53d.tar.gz
MDEV-336 oqgraph 5.5 crashes in buildbot
compile oqgraph with -fno-strict-aliasing
Diffstat (limited to 'storage/oqgraph/CMakeLists.txt')
-rw-r--r--storage/oqgraph/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/storage/oqgraph/CMakeLists.txt b/storage/oqgraph/CMakeLists.txt
index ecd2d46dad3..83acb99b2a2 100644
--- a/storage/oqgraph/CMakeLists.txt
+++ b/storage/oqgraph/CMakeLists.txt
@@ -26,7 +26,7 @@ IF(BOOST_OK)
IF(MSVC)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /EHsc")
ELSE(MSVC)
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-deprecated")
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-deprecated -fno-strict-aliasing")
STRING(REPLACE "-fno-exceptions" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "-fno-implicit-templates" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
ENDIF(MSVC)