summaryrefslogtreecommitdiff
path: root/storage/perfschema/CMakeLists.txt
diff options
context:
space:
mode:
authorEtienne Guesnet <etienne.guesnet.external@atos.net>2020-01-31 14:37:44 +0100
committerDaniel Black <daniel@mariadb.org>2020-12-16 08:07:04 +1100
commit2f5d372444cff53914cfcd118e92a91f575cec35 (patch)
tree8a9e82016a1c4f564f1dc44ff74280af9c8ac5be /storage/perfschema/CMakeLists.txt
parentee69c153d9a20675dcfb368ab52b7a63d15f112d (diff)
downloadmariadb-git-2f5d372444cff53914cfcd118e92a91f575cec35.tar.gz
Add build on AIX
Diffstat (limited to 'storage/perfschema/CMakeLists.txt')
-rw-r--r--storage/perfschema/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/storage/perfschema/CMakeLists.txt b/storage/perfschema/CMakeLists.txt
index a40e5ba6206..b2388099328 100644
--- a/storage/perfschema/CMakeLists.txt
+++ b/storage/perfschema/CMakeLists.txt
@@ -33,6 +33,11 @@ IF (SSL_DEFINES)
ADD_DEFINITIONS(${SSL_DEFINES})
ENDIF()
+IF(CMAKE_SYSTEM_NAME MATCHES AIX)
+ # Workaround linker bug on AIX
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-berok")
+ENDIF()
+
#
# Maintainer: keep this list sorted, to avoid merge collisions.
# Tip: ls -1 *.h, ls -1 *.cc