summaryrefslogtreecommitdiff
path: root/storage/xtradb/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2016-09-10 16:04:44 +0200
committerSergei Golubchik <serg@mariadb.org>2016-09-10 16:04:44 +0200
commitd019af402cdaa80bd03ad8a5cf2c11cf54443248 (patch)
treebcbe5acdb8804a3087639b6d9de70c3d1149cb65 /storage/xtradb/CMakeLists.txt
parentd8cbad069acd171c0b9d417fbda74aaf1f3c96a1 (diff)
downloadmariadb-git-d019af402cdaa80bd03ad8a5cf2c11cf54443248.tar.gz
misc after-merge changes:
* remove new InnoDB-specific ER_ and HA_ERR_ codes * renamed few old ER_ and HA_ERR_ error messages to be less MyISAM-specific * remove duplicate enum definitions (durability_properties, icp_result) * move new mysql-test include files to their owner suite * rename xtradb.rdiff files to *-disabled * remove mistakenly committed helper perl module * remove long obsolete handler::ha_statistic_increment() method * restore the standard C xid_t structure to not have setters and getters * remove xid_t::reset that was cleaning too much * move MySQL-5.7 ER_ codes where they belong * fir innodb to include service_wsrep.h not internal wsrep headers * update tests and results
Diffstat (limited to 'storage/xtradb/CMakeLists.txt')
-rw-r--r--storage/xtradb/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/storage/xtradb/CMakeLists.txt b/storage/xtradb/CMakeLists.txt
index a55671504ea..a9a4d422143 100644
--- a/storage/xtradb/CMakeLists.txt
+++ b/storage/xtradb/CMakeLists.txt
@@ -505,7 +505,8 @@ IF(CMAKE_SYSTEM_PROCESSOR MATCHES "ppc64le")
ENDIF()
MYSQL_ADD_PLUGIN(xtradb ${INNOBASE_SOURCES} STORAGE_ENGINE
- DISABLED RECOMPILE_FOR_EMBEDDED
+ DISABLED # until upgraded to 5.7, see also mysql-test/include/have_xtradb.combinations
+ RECOMPILE_FOR_EMBEDDED
LINK_LIBRARIES ${ZLIB_LIBRARY} ${LINKER_SCRIPT})
IF(TARGET xtradb AND NOT XTRADB_OK)