summaryrefslogtreecommitdiff
path: root/strings/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Petrunya <psergey@askmonty.org>2009-09-01 15:59:54 +0400
committerSergey Petrunya <psergey@askmonty.org>2009-09-01 15:59:54 +0400
commitd841ea23ef0465e7cc0a060a1b1a6faf0f4804b8 (patch)
tree9f5d95c5ce014509325bad61aa5ca855efb952c3 /strings/CMakeLists.txt
parent177f024954283c372a7f6d0b56354e2d61a81eb4 (diff)
downloadmariadb-git-d841ea23ef0465e7cc0a060a1b1a6faf0f4804b8.tar.gz
Trivial fixes for windows compile failures
- Add strmov_overlapp.c where it's needed - Add libevent where it is required - Fix typo in unittest/mysys/waiting_threads-t.c - fix xtradb C language source so that they have variable declarations before any operators, as it is (or was?) required in C. libmysql/CMakeLists.txt: - Add strmov_overlapp.c where it's needed sql/CMakeLists.txt: - Add strmov_overlapp.c where it's needed - Add libevent where it is required storage/xtradb/btr/btr0cur.c: - fix xtradb C language source so that they have variable declarations before any operators, as it is (or was?) required in C. storage/xtradb/buf/buf0buddy.c: - fix xtradb C language source so that they have variable declarations before any operators, as it is (or was?) required in C. storage/xtradb/buf/buf0flu.c: - fix xtradb C language source so that they have variable declarations before any operators, as it is (or was?) required in C. storage/xtradb/fil/fil0fil.c: - fix xtradb C language source so that they have variable declarations before any operators, as it is (or was?) required in C. storage/xtradb/handler/i_s.cc: - fix xtradb C language source so that they have variable declarations before any operators, as it is (or was?) required in C. storage/xtradb/srv/srv0srv.c: - fix xtradb C language source so that they have variable declarations before any operators, as it is (or was?) required in C. strings/CMakeLists.txt: - Add strmov_overlapp.c where it's needed unittest/mysys/waiting_threads-t.c: - Fix typo in unittest/mysys/waiting_threads-t.c
Diffstat (limited to 'strings/CMakeLists.txt')
-rwxr-xr-xstrings/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/strings/CMakeLists.txt b/strings/CMakeLists.txt
index f57189bd548..5ba1c0e5747 100755
--- a/strings/CMakeLists.txt
+++ b/strings/CMakeLists.txt
@@ -23,7 +23,7 @@ SET(STRINGS_SOURCES bchange.c bcmp.c bfill.c bmove512.c bmove_upp.c ctype-big5.c
ctype-latin1.c ctype-mb.c ctype-simple.c ctype-sjis.c ctype-tis620.c ctype-uca.c
ctype-ucs2.c ctype-ujis.c ctype-utf8.c ctype-win1250ch.c ctype.c decimal.c int2str.c
is_prefix.c llstr.c longlong2str.c my_strtoll10.c my_vsnprintf.c r_strinstr.c
- str2int.c str_alloc.c strcend.c strend.c strfill.c strmake.c strmov.c strnmov.c
+ str2int.c str_alloc.c strcend.c strend.c strfill.c strmake.c strmov.c strmov_overlapp.c strnmov.c
strtod.c strtol.c strtoll.c strtoul.c strtoull.c strxmov.c strxnmov.c xml.c
my_strchr.c strcont.c strinstr.c strnlen.c
strappend.c)