summaryrefslogtreecommitdiff
path: root/support-files/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <sergii@pisem.net>2012-05-25 19:18:29 +0200
committerSergei Golubchik <sergii@pisem.net>2012-05-25 19:18:29 +0200
commitbe0d1179a87298a6ffc02e55a12e8e3a38d1e3c8 (patch)
treee7adb09daa8cd8309833643491694d6e99499bf5 /support-files/CMakeLists.txt
parent01a364a0ca31e80a5946597b6fccd96ff2fa723a (diff)
downloadmariadb-git-be0d1179a87298a6ffc02e55a12e8e3a38d1e3c8.tar.gz
create a new MariaDB-common.rpm that contains files needed both by the client and the server.
use my.cnf includes to split one big my.cnf file in server and client parts. remove "Provides: mysql-libs" (doesn't help on CentOS 6)
Diffstat (limited to 'support-files/CMakeLists.txt')
-rw-r--r--support-files/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/support-files/CMakeLists.txt b/support-files/CMakeLists.txt
index 177980414ca..fde4746df16 100644
--- a/support-files/CMakeLists.txt
+++ b/support-files/CMakeLists.txt
@@ -102,6 +102,16 @@ IF(UNIX)
RENAME mysql COMPONENT SupportFiles
PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ
GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+
+ INSTALL(FILES rpm/my.cnf DESTINATION ${INSTALL_SYSCONFDIR}
+ COMPONENT Common)
+ INSTALL(FILES rpm/client.cnf DESTINATION ${INSTALL_SYSCONFDIR}/my.cnf.d
+ COMPONENT SharedLibraries)
+ INSTALL(FILES rpm/mysql-clients.cnf DESTINATION ${INSTALL_SYSCONFDIR}/my.cnf.d
+ COMPONENT Client)
+ INSTALL(FILES rpm/server.cnf DESTINATION ${INSTALL_SYSCONFDIR}/my.cnf.d
+ COMPONENT IniFiles)
+
# This is for SuSE:
INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${CMAKE_COMMAND} -E create_symlink
${INSTALL_SYSCONFDIR}/init.d/mysql