summaryrefslogtreecommitdiff
path: root/support-files/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-09-26 20:19:33 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-09-26 20:19:33 +0200
commit16c09e69f63653042d678c62b1a6633bab2f35b2 (patch)
treeb4ba6e88cb9375177f5fe55d16e011c50941e6f8 /support-files/Makefile.am
parent4cfe994ebcc9c9f1ff710694916a1d6b1e22af7f (diff)
downloadmariadb-git-16c09e69f63653042d678c62b1a6633bab2f35b2.tar.gz
make_binary_distribution.sh:
Use 'make install' to create the package Makefile.am: Added 'pkgsuppdir' to control location separately Pass on mandir and infodir Don't install headers scripts/Makefile.am: Pass on mandir and infodir scripts/make_binary_distribution.sh: Use 'make install' to create the package support-files/Makefile.am: Added 'pkgsuppdir' to control location separately cmd-line-utils/readline/Makefile.am: Don't install headers cmd-line-utils/libedit/Makefile.am: Don't install headers
Diffstat (limited to 'support-files/Makefile.am')
-rw-r--r--support-files/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/support-files/Makefile.am b/support-files/Makefile.am
index 36dcd36e25b..056a61f2e2a 100644
--- a/support-files/Makefile.am
+++ b/support-files/Makefile.am
@@ -34,7 +34,10 @@ EXTRA_DIST = mysql.spec.sh \
SUBDIRS = MacOSX RHEL4-SElinux
-pkgdata_DATA = my-small.cnf \
+# Default same as 'pkgdatadir', but we can override it
+pkgsuppdir = $(datadir)/@PACKAGE@
+
+pkgsupp_DATA = my-small.cnf \
my-medium.cnf \
my-large.cnf \
my-huge.cnf \
@@ -43,7 +46,7 @@ pkgdata_DATA = my-small.cnf \
binary-configure \
ndb-config-2-node.ini
-pkgdata_SCRIPTS = mysql.server \
+pkgsupp_SCRIPTS = mysql.server \
mysqld_multi.server
aclocaldir = $(datadir)/aclocal