summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@narttu.mysql.fi>2003-05-15 17:50:57 +0300
committerunknown <monty@narttu.mysql.fi>2003-05-15 17:50:57 +0300
commit8178016caee8c98f017a8b8ce1b79802ce3c8231 (patch)
treed3b62b3ee37be2ecb2a5fceeed86d202a191a8f8 /tests/Makefile.am
parentdf9068e35a356b657c6f70c0d8563d3ddae5304c (diff)
downloadmariadb-git-8178016caee8c98f017a8b8ce1b79802ce3c8231.tar.gz
Fix to get thread_test to compile
BitKeeper/etc/ignore: added insert_test tests/thread_test.c: Remove compiler warnings
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 989ddbb02eb..5d6e6a68ae2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -40,6 +40,9 @@ client_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
insert_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
select_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
+# Fix for mit-threads
+DEFS = -DUNDEF_THREADS_HACK
+
thread_test.o: thread_test.c
$(COMPILE) -c @MT_INCLUDES@ $(INCLUDES) $<