summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorkonstantin@mysql.com <>2004-08-03 04:30:31 -0700
committerkonstantin@mysql.com <>2004-08-03 04:30:31 -0700
commitb29ba2284e5d74e75bd664b020c7f2af78f1a918 (patch)
tree1035101390c53f36943ac8e4638ad708a42b5491 /tests/Makefile.am
parent40d5fd0141fe5a01ecdfa983dd8dd6e537583f18 (diff)
downloadmariadb-git-b29ba2284e5d74e75bd664b020c7f2af78f1a918.tar.gz
Followup3: operator new and operator delete are defined in mysys.
The fix makes client_test.cc compile with embedded library.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0a86b330f18..0b2b31ae5a6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -33,8 +33,10 @@ noinst_PROGRAMS = insert_test select_test thread_test client_test
#
INCLUDES = -I$(top_srcdir)/include $(openssl_includes)
LIBS = @CLIENT_LIBS@
-LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysql/libmysqlclient.la
-client_test_LDADD= $(LDADD) $(CXXLDFLAGS)
+LDADD = @CLIENT_EXTRA_LDFLAGS@ \
+ $(top_builddir)/libmysql/libmysqlclient.la
+client_test_LDADD= $(LDADD) $(CXXLDFLAGS) \
+ $(top_builddir)/mysys/libmysys.a
client_test_SOURCES= client_test.cc
insert_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
select_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)