summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authoringo/mydev@chilla.local <>2006-07-20 21:28:55 +0200
committeringo/mydev@chilla.local <>2006-07-20 21:28:55 +0200
commit18a76a953c1d5e39432313ae3b074474183fc1aa (patch)
treed3585cee57a42ed75573a9a112555ccd6e294e90 /tests/Makefile.am
parentacb73b1e7e2d1091098300b6ca07b443eded665a (diff)
parentf631765a069063c6c475bed53176f2692283f70e (diff)
downloadmariadb-git-18a76a953c1d5e39432313ae3b074474183fc1aa.tar.gz
Merge chilla.local:/home/mydev/mysql-5.0-mmerge
into chilla.local:/home/mydev/mysql-5.1-amain
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8ee64f8179c..fd7bc5a532e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -50,8 +50,14 @@ INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
LIBS = @CLIENT_LIBS@
LDADD = @CLIENT_EXTRA_LDFLAGS@ \
$(LIBMYSQLCLIENT_LA)
+if HAVE_NETWARE
+mysql_client_test_LDADD= $(LDADD) $(CXXLDFLAGS)
+mysql_client_test_SOURCES= mysql_client_test.c $(yassl_dummy_link_fix) \
+ ../mysys/my_memmem.c
+else
mysql_client_test_LDADD= $(LDADD) $(CXXLDFLAGS) -L../mysys -lmysys
mysql_client_test_SOURCES= mysql_client_test.c $(yassl_dummy_link_fix)
+endif
insert_test_SOURCES= insert_test.c $(yassl_dummy_link_fix)
select_test_SOURCES= select_test.c $(yassl_dummy_link_fix)
insert_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)