summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2002-10-16 19:31:22 +0300
committerunknown <monty@hundin.mysql.fi>2002-10-16 19:31:22 +0300
commit2cbb3b229f05e6ec7324ddc11adf117974a8211a (patch)
tree89817f579654aba756228a1cc5f4303de19158b0 /tests/Makefile.am
parent320d4912f4e6318d7ac080692ed780b6f1557e54 (diff)
parentb3cb7b7f7742f691c9a14598e455b4ecb96f07e1 (diff)
downloadmariadb-git-2cbb3b229f05e6ec7324ddc11adf117974a8211a.tar.gz
Merge hundin.mysql.fi:/my/mysql-4.0 into hundin.mysql.fi:/my/mysql-4.1
mysql-test/r/null_key.result: Auto merged sql/ha_innodb.cc: Auto merged sql/sql_parse.cc: Auto merged
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cdb623fa2a0..241caf74465 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,7 +24,20 @@ EXTRA_DIST = auto_increment.res auto_increment.tst \
insert_and_repair.pl \
grant.pl grant.res test_delayed_insert.pl \
pmail.pl mail_to_db.pl table_types.pl \
- udf_test udf_test.res
+ udf_test udf_test.res
+
+#
+# C Test for 4.1 protocol
+#
+INCLUDES = -I$(srcdir)/../include $(openssl_includes) \
+ -I../include -I$(srcdir)/.. -I$(top_srcdir) \
+ -I..
+LIBS = @CLIENT_LIBS@
+LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysql/libmysqlclient.la
+noinst_PROGRAMS = client_test
+client_test_LDADD= $(LDADD) $(CXXLDFLAGS)
+client_test_SOURCES= client_test.c
+client_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
# Don't update the files from bitkeeper
%::SCCS/s.%