summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorunknown <svoj@mysql.com>2005-06-12 18:18:46 +0500
committerunknown <svoj@mysql.com>2005-06-12 18:18:46 +0500
commit3d43153655c9c352ce9fc783a0afe8402994f321 (patch)
treeb85af950dec5e1657f0299eb81122f1953146d41 /tests/Makefile.am
parentb85705cce12b178efdfd813de06326882cd24b40 (diff)
downloadmariadb-git-3d43153655c9c352ce9fc783a0afe8402994f321.tar.gz
WL#2286 - Compile MySQL w/YASSL support
Fix for link failures on boxes with non-gnu compiler. client/Makefile.am: Add a dummy C++ file to client suite to make libtool use a C++ linker: this lets client suite link when using yaSSL and a non-gcc C++ compiler. config/ac-macros/yassl.m4: HAVE_YASSL conditional is used to add dummy C++ file if configured with yaSSL. tests/Makefile.am: Add a dummy C++ file to tests to make libtool use a C++ linker: this lets tests link when using yaSSL and a non-gcc C++ compiler. vio/Makefile.am: Use dummy C++ file if configured with yaSSL only.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a4bcd38afb1..ee3e31aa040 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -17,6 +17,11 @@
## Process this file with automake to create Makefile.in
+if HAVE_YASSL
+ yassl_dummy_link_fix= $(top_srcdir)/extra/yassl/src/dummy.cpp
+else
+ yassl_dummy_link_fix=
+endif
EXTRA_DIST = auto_increment.res auto_increment.tst \
function.res function.tst lock_test.pl lock_test.res \
export.pl big_record.pl \
@@ -38,7 +43,9 @@ LDADD = @CLIENT_EXTRA_LDFLAGS@ \
$(top_builddir)/libmysql/libmysqlclient.la
mysql_client_test_LDADD= $(LDADD) $(CXXLDFLAGS) \
$(top_builddir)/mysys/libmysys.a
-mysql_client_test_SOURCES= mysql_client_test.c
+mysql_client_test_SOURCES= mysql_client_test.c $(yassl_dummy_link_fix)
+insert_test_SOURCES= insert_test.c $(yassl_dummy_link_fix)
+select_test_SOURCES= select_test.c $(yassl_dummy_link_fix)
insert_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
select_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)