summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorunknown <sasha@mysql.sashanet.com>2001-08-27 17:33:11 -0600
committerunknown <sasha@mysql.sashanet.com>2001-08-27 17:33:11 -0600
commit5e878c0d9a7f08021f7b77a7a064335b52246fc5 (patch)
tree0a747a3ef29d7575773417245b77e6f465e37496 /tools/Makefile.am
parent8d982e7690275491fe71bafc917486d7f61ea12c (diff)
downloadmariadb-git-5e878c0d9a7f08021f7b77a7a064335b52246fc5.tar.gz
work on MySQL server management daemon
BitKeeper/etc/ignore: Added linked_tools_sources tools/my_vsnprintf.c tools/mysqlmngd tools/mysys_priv.h to the ignore list Makefile.am: fixes for tools directory configure.in: fixes for tools directory tools/mysqlmngd.c: some bare-bones server code
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 00000000000..0b84298a829
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = -I$(srcdir)/../include $(openssl_includes) \
+ -I../include -I$(srcdir)/.. -I$(top_srcdir) \
+ -I..
+LIBS = @TOOLS_LIBS@
+LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysql_r/libmysqlclient_r.la
+bin_PROGRAMS = mysqlmngd
+mysqlmngd_SOURCES = mysqlmngd.c my_vsnprintf.c
+mysqltest_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
+DEFS = -DUNDEF_THREADS_HACK
+
+mysys_src=my_vsnprintf.c mysys_priv.h
+
+link_sources:
+ for f in $(mysys_src); do \
+ rm -f $$f; \
+ @LN_CP_F@ ../mysys/$$f $$f; \
+ done;
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%
+
+