summaryrefslogtreecommitdiff
path: root/unittest/Makefile.am
diff options
context:
space:
mode:
authormats@mysql.com <>2006-04-06 17:18:12 +0200
committermats@mysql.com <>2006-04-06 17:18:12 +0200
commit32c697806f04ba0272ebfd55f65cfae18b826037 (patch)
tree921b8b2e75695922185e05e1e19a3d6eee2e5e41 /unittest/Makefile.am
parent9b087e7d45007058e2ee8c3915cd2aea909a7fcd (diff)
downloadmariadb-git-32c697806f04ba0272ebfd55f65cfae18b826037.tar.gz
WL#3206 (Adding unit tests):
Moving mytap library into unittest/ Adding 'test' target to make and run unit tests. Minor fixes.
Diffstat (limited to 'unittest/Makefile.am')
-rw-r--r--unittest/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/unittest/Makefile.am b/unittest/Makefile.am
index 54142b1e08d..3e7fc37e4f6 100644
--- a/unittest/Makefile.am
+++ b/unittest/Makefile.am
@@ -1 +1,21 @@
-SUBDIRS = mysys examples
+SUBDIRS = mytap . mysys examples
+
+.PHONY: mytap mysys examples test
+
+noinst_SCRIPTS = unit
+
+test: mytap mysys examples
+ ./unit run $^
+
+mytap:
+ cd mytap && $(MAKE)
+
+mysys:
+ cd mysys && $(MAKE)
+
+examples:
+ cd examples && $(MAKE)
+
+unit: unit.pl
+ cp $< $@
+ chmod +x $@