summaryrefslogtreecommitdiff
path: root/unittest/Makefile.am
diff options
context:
space:
mode:
authorserg@serg.mylan <>2006-06-01 12:25:47 +0200
committerserg@serg.mylan <>2006-06-01 12:25:47 +0200
commit5409997d49a8c228f1a6a2c029572fcf1f221caf (patch)
tree445a123eb59c53a13ae718cbc126d350bc89610f /unittest/Makefile.am
parent2b9b84460aa3e2b0dce089a4067052a16dab7278 (diff)
downloadmariadb-git-5409997d49a8c228f1a6a2c029572fcf1f221caf.tar.gz
unittest:
rename *.t* to *-t* to be automake-friendly simplify Makefiles test_atomic.c: move to unittest, add GPL comment, fix warnings, convert to tap framework. configure: remove custom tests for available types, use AC_CHECK_TYPE instead x86-gcc.h: fix gcc -ansi errors while maintaining readability ignore: added *-t
Diffstat (limited to 'unittest/Makefile.am')
-rw-r--r--unittest/Makefile.am25
1 files changed, 6 insertions, 19 deletions
diff --git a/unittest/Makefile.am b/unittest/Makefile.am
index bfa9f40f8ce..dc778aada1c 100644
--- a/unittest/Makefile.am
+++ b/unittest/Makefile.am
@@ -1,27 +1,14 @@
SUBDIRS = mytap . mysys examples
noinst_SCRIPTS = unit
+#EXTRA_DIST = unit.pl
-EXTRA_DIST = unit.pl
+unittests = mytap mysys
-DISTCLEANFILES = unit
-
-unittests = mysys examples
-
-.PHONY: all mytap mysys examples test
-
-test: unit all
- @./unit run $(unittests)
-
-mytap:
- cd mytap && $(MAKE)
-
-mysys:
- cd mysys && $(MAKE)
-
-examples:
- cd examples && $(MAKE)
+test: unit
+ ./unit run $(unittests)
unit: $(srcdir)/unit.pl
cp $(srcdir)/unit.pl $@
- chmod +x $@
+ chmod 700 $@
+