summaryrefslogtreecommitdiff
path: root/unittest/Makefile.am
diff options
context:
space:
mode:
authorunknown <jimw@mysql.com>2006-04-13 13:01:57 -0700
committerunknown <jimw@mysql.com>2006-04-13 13:01:57 -0700
commitd23064a668e555c7b87c526b2e2bd76dd6f9d83a (patch)
treec1e9f2b1d43080af258cb346f4df22c09ced3b56 /unittest/Makefile.am
parentc323e60c46c73efde0efea3ff056f83e17cb9009 (diff)
downloadmariadb-git-d23064a668e555c7b87c526b2e2bd76dd6f9d83a.tar.gz
Fix 'make distcheck' problems with new unittest code, and a small
portability problem. BitKeeper/etc/ignore: Use a wildcard to ignore all unittest *.t files unittest/Makefile.am: Add unit to DISTCLEANFILES, and make sure to copy it from srcdir unittest/examples/Makefile.am: Use srcdir to find mytap header unittest/mysys/Makefile.am: Use srcdir to find mytap header unittest/mytap/t/Makefile.am: Use builddir for finding mytap library unittest/mytap/tap.c: Fix portability problem (declarations after code in C code)
Diffstat (limited to 'unittest/Makefile.am')
-rw-r--r--unittest/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/unittest/Makefile.am b/unittest/Makefile.am
index 8943e58170d..f6dfb41e4e1 100644
--- a/unittest/Makefile.am
+++ b/unittest/Makefile.am
@@ -2,6 +2,8 @@ SUBDIRS = mytap . mysys examples
noinst_SCRIPTS = unit
+DISTCLEANFILES = unit
+
unittests = mysys examples
.PHONY: all mytap mysys examples test
@@ -18,6 +20,6 @@ mysys:
examples:
cd examples && $(MAKE)
-unit: unit.pl
+unit: $(srcdir)/unit.pl
cp $< $@
chmod +x $@