summaryrefslogtreecommitdiff
path: root/unittest/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Alff <marc.alff@sun.com>2009-11-17 21:29:26 -0700
committerMarc Alff <marc.alff@sun.com>2009-11-17 21:29:26 -0700
commit48ea0b83a0a19b2107df4300bda211206b37ea20 (patch)
tree82ff91bb12c9ad25f14d3ff86735d39d819703bb /unittest/examples/CMakeLists.txt
parent244eced1a797f15dd0ebe0a58b6c054c26b4fa28 (diff)
downloadmariadb-git-48ea0b83a0a19b2107df4300bda211206b37ea20.tar.gz
Port the unit test framework to windows
Backport from 6.0.14 to 5.6.0 Original code from Guilhem Bichot
Diffstat (limited to 'unittest/examples/CMakeLists.txt')
-rw-r--r--unittest/examples/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/unittest/examples/CMakeLists.txt b/unittest/examples/CMakeLists.txt
new file mode 100644
index 00000000000..a5aa5a93985
--- /dev/null
+++ b/unittest/examples/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Copyright (C) 2007 MySQL AB
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/zlib
+ ${CMAKE_SOURCE_DIR}/sql
+ ${CMAKE_SOURCE_DIR}/regex
+ ${CMAKE_SOURCE_DIR}/extra/yassl/include
+ ${CMAKE_SOURCE_DIR}/unittest/mytap)
+ADD_EXECUTABLE(simple-t simple-t.c)
+TARGET_LINK_LIBRARIES(simple-t mytap)
+
+ADD_EXECUTABLE(skip-t skip-t.c)
+TARGET_LINK_LIBRARIES(skip-t mytap)
+
+ADD_EXECUTABLE(todo-t todo-t.c)
+TARGET_LINK_LIBRARIES(todo-t mytap)
+
+ADD_EXECUTABLE(skip_all-t skip_all-t.c)
+TARGET_LINK_LIBRARIES(skip_all-t mytap)
+
+ADD_EXECUTABLE(no_plan-t no_plan-t.c)
+TARGET_LINK_LIBRARIES(no_plan-t mytap)
+
+ADD_EXECUTABLE(core-t core-t.c)
+TARGET_LINK_LIBRARIES(core-t mytap)