summaryrefslogtreecommitdiff
path: root/unittest/mysys/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2020-04-28 11:20:52 +0200
committerSergei Golubchik <serg@mariadb.org>2020-04-30 10:13:21 +0200
commit6a31aea5a1a50614af3a6591a085dc47061cdd0e (patch)
tree0ccf8380952f2ec100acb5719001523ed3a5ba91 /unittest/mysys/CMakeLists.txt
parent69bd73173d041a06504161a0b93bb529737f2c84 (diff)
downloadmariadb-git-6a31aea5a1a50614af3a6591a085dc47061cdd0e.tar.gz
BUG#30301356 - SOME EVENTS ARE DELAYED AFTER DROPPING EVENT
queues.c cleanup and refactoring. Restore old version of _downhead() (from before cd483c55209) that works well in an average case. Use it for queue_fix(). Move existing specialized version of _downhead() to queue_replace() where it'll be handling the case it was specifically optimized for (moving the element to the end of the queue). And correct it to fix the heap not only down, but also up (this fixes BUG#30301356). Add unit tests. Collateral cosmetic fixes.
Diffstat (limited to 'unittest/mysys/CMakeLists.txt')
-rw-r--r--unittest/mysys/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/unittest/mysys/CMakeLists.txt b/unittest/mysys/CMakeLists.txt
index de7efeaaaec..21be7e82cda 100644
--- a/unittest/mysys/CMakeLists.txt
+++ b/unittest/mysys/CMakeLists.txt
@@ -14,7 +14,7 @@
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA
MY_ADD_TESTS(bitmap base64 my_atomic my_rdtsc lf my_malloc my_getopt dynstring
- LINK_LIBRARIES mysys)
+ queues LINK_LIBRARIES mysys)
MY_ADD_TESTS(my_vsnprintf LINK_LIBRARIES strings mysys)
IF(WIN32)