summaryrefslogtreecommitdiff
path: root/unittest/mysys/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Alff <marc.alff@sun.com>2009-11-24 16:36:31 -0700
committerMarc Alff <marc.alff@sun.com>2009-11-24 16:36:31 -0700
commite2a34cbf706926e10016079a094a2877eb2f4f18 (patch)
tree06a753b068f7fb21faaa840cf0808981acaaabb2 /unittest/mysys/CMakeLists.txt
parent23159440504311372b2c081c1b5f2cb2f7d98ef3 (diff)
downloadmariadb-git-e2a34cbf706926e10016079a094a2877eb2f4f18.tar.gz
WL#2373 Use cycle counter for timing
Diffstat (limited to 'unittest/mysys/CMakeLists.txt')
-rw-r--r--unittest/mysys/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/unittest/mysys/CMakeLists.txt b/unittest/mysys/CMakeLists.txt
new file mode 100644
index 00000000000..a4c79afbf8b
--- /dev/null
+++ b/unittest/mysys/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright (C) 2007 MySQL AB, 2008-2009 Sun Microsystems, Inc
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/zlib
+ ${CMAKE_SOURCE_DIR}/sql
+ ${CMAKE_SOURCE_DIR}/regex
+ ${CMAKE_SOURCE_DIR}/extra/yassl/include
+ ${CMAKE_SOURCE_DIR}/unittest/mytap)
+ADD_EXECUTABLE(bitmap-t bitmap-t.c)
+TARGET_LINK_LIBRARIES(bitmap-t mytap mysys dbug strings)
+
+ADD_EXECUTABLE(base64-t base64-t.c)
+TARGET_LINK_LIBRARIES(base64-t mytap mysys dbug strings)
+
+ADD_EXECUTABLE(my_atomic-t my_atomic-t.c)
+TARGET_LINK_LIBRARIES(my_atomic-t mytap mysys dbug strings)
+
+ADD_EXECUTABLE(lf-t lf-t.c)
+TARGET_LINK_LIBRARIES(lf-t mytap mysys dbug strings)
+
+ADD_EXECUTABLE(my_rdtsc-t my_rdtsc-t.c)
+TARGET_LINK_LIBRARIES(my_rdtsc-t mytap mysys dbug strings)
+