summaryrefslogtreecommitdiff
path: root/unittest/mysys/Makefile.am
diff options
context:
space:
mode:
authorunknown <mats@mysql.com>2006-04-06 17:18:12 +0200
committerunknown <mats@mysql.com>2006-04-06 17:18:12 +0200
commit3f9e35d3f350768a8d237bfd369adf63f565f81c (patch)
tree921b8b2e75695922185e05e1e19a3d6eee2e5e41 /unittest/mysys/Makefile.am
parentb0d2b6588be8b5c1854b6e0311fcbd42f97b9c18 (diff)
downloadmariadb-git-3f9e35d3f350768a8d237bfd369adf63f565f81c.tar.gz
WL#3206 (Adding unit tests):
Moving mytap library into unittest/ Adding 'test' target to make and run unit tests. Minor fixes. unittest/mytap/Doxyfile: mvdir unittest/mytap/t/basic.t.c: mvdir unittest/mytap/tap.c: mvdir unittest/mytap/tap.h: mvdir Makefile.am: Correcting after moving mytap/ configure.in: Correcting after moving mytap/ unittest/Makefile.am: Adding 'test' target to build and execute unit tests. unittest/examples/Makefile.am: Correcting after moving mytap/ unittest/mysys/Makefile.am: Correcting after moving mytap/ unittest/mysys/bitmap.t.c: Adding copyright notice. unittest/mytap/Makefile.am: Correcting after moving mytap/ unittest/mytap/t/Makefile.am: Correcting after moving mytap/ unittest/mysys/base64.t.c: New BitKeeper file ``unittest/mysys/base64.t.c''
Diffstat (limited to 'unittest/mysys/Makefile.am')
-rw-r--r--unittest/mysys/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/unittest/mysys/Makefile.am b/unittest/mysys/Makefile.am
index 4d725facc52..248dda84f7e 100644
--- a/unittest/mysys/Makefile.am
+++ b/unittest/mysys/Makefile.am
@@ -1,14 +1,15 @@
-AM_CPPFLAGS = -I$(srcdir) -I$(top_builddir)/include
-AM_CPPFLAGS += -I$(top_builddir)/mytap
+AM_CPPFLAGS = @ZLIB_INCLUDES@ -I$(top_builddir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/include -I$(top_builddir)/unittest/mytap
-AM_CFLAGS = -Wall -ansi -pedantic
+AM_LDFLAGS = -L$(top_builddir)/unittest/mytap -L$(top_builddir)/mysys
+AM_LDFLAGS += -L$(top_builddir)/strings -L$(top_builddir)/dbug
-AM_LDFLAGS = -L$(top_builddir)/mytap -L$(top_builddir)/mysys
-AM_LDFLAGS += -L$(top_builddir)/strings
+LDADD = -lmytap -lmysys -lmystrings -ldbug
-LDADD = -lmytap -lmysys -lmystrings
-
-noinst_PROGRAMS = bitmap.t
+noinst_PROGRAMS = bitmap.t base64.t
bitmap_t_SOURCES = bitmap.t.c
+
+base64_t_SOURCES = base64.t.c
+