summaryrefslogtreecommitdiff
path: root/unittest/mytap/Makefile.am
diff options
context:
space:
mode:
authorunknown <mats@mysql.com>2006-04-06 17:18:12 +0200
committerunknown <mats@mysql.com>2006-04-06 17:18:12 +0200
commit3f9e35d3f350768a8d237bfd369adf63f565f81c (patch)
tree921b8b2e75695922185e05e1e19a3d6eee2e5e41 /unittest/mytap/Makefile.am
parentb0d2b6588be8b5c1854b6e0311fcbd42f97b9c18 (diff)
downloadmariadb-git-3f9e35d3f350768a8d237bfd369adf63f565f81c.tar.gz
WL#3206 (Adding unit tests):
Moving mytap library into unittest/ Adding 'test' target to make and run unit tests. Minor fixes. unittest/mytap/Doxyfile: mvdir unittest/mytap/t/basic.t.c: mvdir unittest/mytap/tap.c: mvdir unittest/mytap/tap.h: mvdir Makefile.am: Correcting after moving mytap/ configure.in: Correcting after moving mytap/ unittest/Makefile.am: Adding 'test' target to build and execute unit tests. unittest/examples/Makefile.am: Correcting after moving mytap/ unittest/mysys/Makefile.am: Correcting after moving mytap/ unittest/mysys/bitmap.t.c: Adding copyright notice. unittest/mytap/Makefile.am: Correcting after moving mytap/ unittest/mytap/t/Makefile.am: Correcting after moving mytap/ unittest/mysys/base64.t.c: New BitKeeper file ``unittest/mysys/base64.t.c''
Diffstat (limited to 'unittest/mytap/Makefile.am')
-rw-r--r--unittest/mytap/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/unittest/mytap/Makefile.am b/unittest/mytap/Makefile.am
new file mode 100644
index 00000000000..2e9fe87709d
--- /dev/null
+++ b/unittest/mytap/Makefile.am
@@ -0,0 +1,9 @@
+
+AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(srcdir)
+
+noinst_LIBRARIES = libmytap.a
+noinst_HEADERS = tap.h
+
+libmytap_a_SOURCES = tap.c
+
+SUBDIRS = . t