summaryrefslogtreecommitdiff
path: root/vio/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-08-06 23:16:01 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-08-06 23:16:01 +0200
commit1337c429fb559242bcafb3ca29de65dfa48a89d5 (patch)
tree7b218053b942a53e4c500c94ca3a1c0d7464d859 /vio/CMakeLists.txt
parente4d449a655ac16d43642cf5d57769c68468c979b (diff)
downloadmariadb-git-1337c429fb559242bcafb3ca29de65dfa48a89d5.tar.gz
CMakeLists.txt (many), win/README, mysql_manifest.cmake, configure.js:
Additional changes for bug#29903 - Changed to do embedded build part as normal build, when WITH_EMBEDDED_SERVER is set. - Allow both normal and debug build with embedded. - Build static embedded library by pointing out all source and compile it all, i.e. not building libraries from libraries, not portable. - Let embedded use generated files from the "sql" directory, added dependencies to make sure built before embedded. - Mark library "dbug" in TARGET_LINK_LIBRARIES() with "debug", so only linked in when debug target is used. - Removed change of target name with "mysqld${MYSQLD_EXE_SUFFIX}", as others can't depend on it, not defined at configure time. Instead set the output file name. - Created work around for bug in CMake 2.4.6 and output names, to set the "mysqld<suffix>.pdb" name to the same base name. - Set the correct manifest "name" (patch by iggy) CMakeLists.txt: Changes for embedded and Windows libmysql/CMakeLists.txt: Changes for embedded and Windows libmysqld/CMakeLists.txt: Changes for embedded and Windows libmysqld/examples/CMakeLists.txt: Changes for embedded and Windows mysys/CMakeLists.txt: Changes for embedded and Windows regex/CMakeLists.txt: Changes for embedded and Windows server-tools/instance-manager/CMakeLists.txt: Changes for embedded and Windows sql/CMakeLists.txt: Changes for embedded and Windows storage/archive/CMakeLists.txt: Changes for embedded and Windows storage/blackhole/CMakeLists.txt: Changes for embedded and Windows storage/csv/CMakeLists.txt: Changes for embedded and Windows storage/example/CMakeLists.txt: Changes for embedded and Windows storage/federated/CMakeLists.txt: Changes for embedded and Windows storage/heap/CMakeLists.txt: Changes for embedded and Windows storage/innobase/CMakeLists.txt: Changes for embedded and Windows storage/myisam/CMakeLists.txt: Changes for embedded and Windows storage/myisammrg/CMakeLists.txt: Changes for embedded and Windows strings/CMakeLists.txt: Changes for embedded and Windows vio/CMakeLists.txt: Changes for embedded and Windows win/README: Changes for embedded and Windows win/configure.js: Changes for embedded and Windows win/mysql_manifest.cmake: Changes for embedded and Windows
Diffstat (limited to 'vio/CMakeLists.txt')
-rwxr-xr-xvio/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/vio/CMakeLists.txt b/vio/CMakeLists.txt
index e4940d54da8..83cd6f65e6d 100755
--- a/vio/CMakeLists.txt
+++ b/vio/CMakeLists.txt
@@ -18,4 +18,10 @@ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG -DSAFEMALLOC -DSAFE_MUT
ADD_DEFINITIONS(-DUSE_SYMDIR)
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/extra/yassl/include)
-ADD_LIBRARY(vio vio.c viosocket.c viossl.c viosslfactories.c)
+
+SET(VIO_SOURCES vio.c viosocket.c viossl.c viosslfactories.c)
+
+IF(NOT SOURCE_SUBLIBS)
+ ADD_LIBRARY(vio ${VIO_SOURCES})
+ENDIF(NOT SOURCE_SUBLIBS)
+