summaryrefslogtreecommitdiff
path: root/vio/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@koala>2009-12-07 02:16:05 +0100
committerVladislav Vaintroub <vvaintroub@koala>2009-12-07 02:16:05 +0100
commit9fcef3c45bd936b7da20679a1bb160c22f4945ff (patch)
treebe34c035a12551aff48f3bcdb4fcbf4754f8b3f0 /vio/CMakeLists.txt
parent2e6270311467f557a424a15b03d8d52c5b0ea92d (diff)
downloadmariadb-git-9fcef3c45bd936b7da20679a1bb160c22f4945ff.tar.gz
On Linux, support -Wl,--no-undefined (only client shared library)
and --Wl,--as-needed (all shared modules). The later will remove unused dependencies (also from gcc and C++ runtime)
Diffstat (limited to 'vio/CMakeLists.txt')
-rwxr-xr-xvio/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/vio/CMakeLists.txt b/vio/CMakeLists.txt
index 3470db61c60..dae2ed2bb2f 100755
--- a/vio/CMakeLists.txt
+++ b/vio/CMakeLists.txt
@@ -20,3 +20,4 @@ ADD_DEFINITIONS(${SSL_DEFINES})
SET(VIO_SOURCES vio.c viosocket.c viossl.c viosslfactories.c)
ADD_CONVENIENCE_LIBRARY(vio ${VIO_SOURCES})
+TARGET_LINK_LIBRARIES(vio ${LIBSOCKET})