summaryrefslogtreecommitdiff
path: root/vio/Makefile.am
diff options
context:
space:
mode:
authorunknown <sasha@mysql.sashanet.com>2002-03-30 16:24:30 -0700
committerunknown <sasha@mysql.sashanet.com>2002-03-30 16:24:30 -0700
commit869e671f98b1a056595e259283bf4e5e40256a20 (patch)
treef611ec442ca101c4c2ac5d8133a9ddd352ae197b /vio/Makefile.am
parent72f1fc7e36a15b59f22dee2639d80cd2538f692d (diff)
downloadmariadb-git-869e671f98b1a056595e259283bf4e5e40256a20.tar.gz
fix to make the compile work with --with-other-libc
libmysqld/examples/Makefile.am: honor client link flags in libmysqld example builds vio/Makefile.am: honor client link flags in vio test program builds
Diffstat (limited to 'vio/Makefile.am')
-rw-r--r--vio/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/vio/Makefile.am b/vio/Makefile.am
index 7119c278862..b512ec33777 100644
--- a/vio/Makefile.am
+++ b/vio/Makefile.am
@@ -15,18 +15,18 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
INCLUDES = -I$(srcdir)/../include -I../include $(openssl_includes)
-LDADD = libvio.a $(openssl_libs)
+LDADD = @CLIENT_EXTRA_LDFLAGS@ libvio.a $(openssl_libs)
pkglib_LIBRARIES = libvio.a
noinst_PROGRAMS = test-ssl test-sslserver test-sslclient
noinst_HEADERS =
test_ssl_SOURCES = test-ssl.c
-test_ssl_LDADD = ../dbug/libdbug.a libvio.a ../mysys/libmysys.a \
+test_ssl_LDADD = @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a ../mysys/libmysys.a \
../strings/libmystrings.a libvio.a $(openssl_libs)
test_sslserver_SOURCES = test-sslserver.c
-test_sslserver_LDADD = ../dbug/libdbug.a libvio.a ../mysys/libmysys.a \
+test_sslserver_LDADD = @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a ../mysys/libmysys.a \
../strings/libmystrings.a libvio.a $(openssl_libs)
test_sslclient_SOURCES = test-sslclient.c
-test_sslclient_LDADD = ../dbug/libdbug.a libvio.a ../mysys/libmysys.a \
+test_sslclient_LDADD = @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a ../mysys/libmysys.a \
../strings/libmystrings.a libvio.a $(openssl_libs)
libvio_a_SOURCES = vio.c viosocket.c viossl.c viosslfactories.c