summaryrefslogtreecommitdiff
path: root/vio/Makefile.am
diff options
context:
space:
mode:
authorunknown <konstantin@mysql.com>2005-05-20 18:35:49 +0400
committerunknown <konstantin@mysql.com>2005-05-20 18:35:49 +0400
commit27b7f85a0beafedfe97e8a95b9599ac0c0f53e29 (patch)
tree1d07140c18701ac5e0d4e6098c06d3bbafa37b8f /vio/Makefile.am
parent78d81529f470f30192ac8b256e9e893062573c99 (diff)
downloadmariadb-git-27b7f85a0beafedfe97e8a95b9599ac0c0f53e29.tar.gz
Fixes for numerous compatibility problems in yaSSL.
extra/yassl/include/openssl/ssl.h: Fix -std=c++98 mode compilation failures. extra/yassl/include/yassl_error.hpp: Fix -std=c++98 mode compilation failures. extra/yassl/include/yassl_types.hpp: Fix -std=c++98 mode compilation failures. extra/yassl/mySTL/helpers.hpp: Fix AIX 5.2 compilation problem. extra/yassl/taocrypt/include/asn.hpp: Fix -std=c++98 mode compilation failures. vio/Makefile.am: Add a dummy C++ file to SSL tests to make libtool use a C++ linker: this lets ssl tests link when using yaSSL and a non-gcc C++ compiler.
Diffstat (limited to 'vio/Makefile.am')
-rw-r--r--vio/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/vio/Makefile.am b/vio/Makefile.am
index 9c961025080..22e706efe4c 100644
--- a/vio/Makefile.am
+++ b/vio/Makefile.am
@@ -19,15 +19,17 @@ LDADD= @CLIENT_EXTRA_LDFLAGS@ $(openssl_libs)
pkglib_LIBRARIES= libvio.a
noinst_PROGRAMS = test-ssl test-sslserver test-sslclient
noinst_HEADERS= vio_priv.h
-test_ssl_SOURCES= test-ssl.c
+test_ssl_SOURCES= test-ssl.c $(top_srcdir)/extra/yassl/src/dummy.cpp
test_ssl_LDADD= @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a \
../mysys/libmysys.a ../strings/libmystrings.a \
$(openssl_libs)
-test_sslserver_SOURCES= test-sslserver.c
+test_sslserver_SOURCES= test-sslserver.c \
+ $(top_srcdir)/extra/yassl/src/dummy.cpp
test_sslserver_LDADD= @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a \
../mysys/libmysys.a ../strings/libmystrings.a \
$(openssl_libs)
-test_sslclient_SOURCES= test-sslclient.c
+test_sslclient_SOURCES= test-sslclient.c \
+ $(top_srcdir)/extra/yassl/src/dummy.cpp
test_sslclient_LDADD= @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a \
../mysys/libmysys.a ../strings/libmystrings.a \
$(openssl_libs)