summaryrefslogtreecommitdiff
path: root/vio/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@shellback.(none)>2006-05-31 16:19:06 +0200
committerunknown <msvensson@shellback.(none)>2006-05-31 16:19:06 +0200
commite03f47859fe2fdbe465613712448a65dcdfc03ac (patch)
treeeec37d5fd4ee259d7eacec279bb80e6952f0a995 /vio/Makefile.am
parentf04b9f247314dfca21cb8bb058537535d5b8c9b0 (diff)
downloadmariadb-git-e03f47859fe2fdbe465613712448a65dcdfc03ac.tar.gz
Bug#19575 MySQL-shared-5.0.21-0.glibc23 causes segfault in SSL_library_init
- Include prefix files that renames all public functions in yaSSLs OpenSSL API to ya<function_name>. They will otherwise conflict with OpenSSL functions if loaded by an application that uses OpenSSL as well as libmysqlclient with yaSSL support. client/Makefile.am: Remove $yassl_includes ...and one "suspicious line" config/ac-macros/yassl.m4: Remove yassl_includes as they are the same as "normal" include extra/yassl/include/openssl/crypto.h: Add include file "prefix_crypto.h" to rename SSL_* functions to yaSSL_* extra/yassl/include/openssl/ssl.h: Add include file "prefix_crypto.h" to rename SSL_* functions to yaSSL_* libmysql/Makefile.am: Remove yassl_includes libmysql_r/Makefile.am: Remove yassl_includes libmysqld/Makefile.am: Remove yassl_includes And one suspicious line libmysqld/examples/Makefile.am: Remove yassl_includes server-tools/instance-manager/Makefile.am: Remove yassl_includes sql/Makefile.am: Remove yassl_includes tools/Makefile.am: Add link with yaSSL libs vio/Makefile.am: Remove yassl_includes extra/yassl/include/openssl/generate_prefix_files.pl: Add utility script to parse the header files to generate the prefix_* files that renames yaSSL SSL_* functions extra/yassl/include/openssl/prefix_crypto.h: Add prefix file for crypto.h extra/yassl/include/openssl/prefix_ssl.h: Add prefix file for ssl.h
Diffstat (limited to 'vio/Makefile.am')
-rw-r--r--vio/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/vio/Makefile.am b/vio/Makefile.am
index 544639139de..e89191d57cd 100644
--- a/vio/Makefile.am
+++ b/vio/Makefile.am
@@ -20,7 +20,7 @@ else
yassl_dummy_link_fix=
endif
INCLUDES= -I$(top_builddir)/include -I$(top_srcdir)/include \
- $(openssl_includes) $(yassl_includes)
+ $(openssl_includes)
LDADD= @CLIENT_EXTRA_LDFLAGS@ $(openssl_libs) $(yassl_libs)
pkglib_LIBRARIES= libvio.a
noinst_PROGRAMS = test-ssl test-sslserver test-sslclient