summaryrefslogtreecommitdiff
path: root/win/Makefile.am
diff options
context:
space:
mode:
authorunknown <knielsen@mysql.com>2006-03-24 22:50:56 +0100
committerunknown <knielsen@mysql.com>2006-03-24 22:50:56 +0100
commit230eab3c68cb26fa743e82d0452f0b83359a10ff (patch)
tree4a3cb807ddfab7cd04cb6caf42623f824843f884 /win/Makefile.am
parenta69a37835c1b3823b359b7a4e1ae7bdafd33a08a (diff)
downloadmariadb-git-230eab3c68cb26fa743e82d0452f0b83359a10ff.tar.gz
Some changes to make it possible to build for Windows with CMake from
a normal 'make dist' source .tar.gz. libmysql/mytest.c: bk cp VC++Files/libmysqltest/mytest.c libmysql/mytest.c sql/message.mc: bk cp VC++Files/sql/message.mc sql/message.mc Makefile.am: Add Windows CMake stuff. client/Makefile.am: Add extra files needed for CMake Windows build. cmakelists.txt: Fix subdir order to make CMake dependency calculations happy. configure.in: Add extra files needed for CMake Windows build. extra/Makefile.am: Add extra files needed for CMake Windows build. extra/yassl/Makefile.am: Add extra files needed for CMake Windows build. libmysql/Makefile.am: Add extra files needed for CMake Windows build. libmysql/cmakelists.txt: Move mytest.c to a more sensible location. libmysqld/Makefile.am: Add extra files needed for CMake Windows build. mysys/Makefile.am: Add extra files needed for CMake Windows build. regex/Makefile.am: Add extra files needed for CMake Windows build. server-tools/instance-manager/Makefile.am: Add extra files needed for CMake Windows build. sql/Makefile.am: Add extra files needed for CMake Windows build. sql/cmakelists.txt: Move message.mc to a more sensible location. Add some dependencies to avoid a stale handlerton.cc. storage/archive/Makefile.am: Add extra files needed for CMake Windows build. storage/bdb/Makefile.in: Add extra files needed for CMake Windows build. storage/example/Makefile.am: Add extra files needed for CMake Windows build. storage/heap/Makefile.am: Add extra files needed for CMake Windows build. storage/innobase/Makefile.am: Add extra files needed for CMake Windows build. storage/innobase/include/univ.i: Avoid including Unix config in Windows build. storage/myisam/Makefile.am: Add extra files needed for CMake Windows build. storage/myisammrg/Makefile.am: Add extra files needed for CMake Windows build. strings/Makefile.am: Add extra files needed for CMake Windows build. tests/Makefile.am: Add extra files needed for CMake Windows build. vio/Makefile.am: Add extra files needed for CMake Windows build. zlib/Makefile.am: Add extra files needed for CMake Windows build.
Diffstat (limited to 'win/Makefile.am')
-rw-r--r--win/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/win/Makefile.am b/win/Makefile.am
new file mode 100644
index 00000000000..8442214bb97
--- /dev/null
+++ b/win/Makefile.am
@@ -0,0 +1,21 @@
+# Copyright (C) 2006 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+## Process this file with automake to create Makefile.in
+EXTRA_DIST = build-vs71.bat build-vs8.bat config-handlerton.js configure.js config-version.js README
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%