summaryrefslogtreecommitdiff
path: root/zlib/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-08-04 00:44:51 +0200
committerunknown <df@pippilotta.erinye.com>2007-08-04 00:44:51 +0200
commitc4c200749a200a7e89ecc6d09c3c41941e0ff50e (patch)
tree5e647c8d2eafbe6efdbb0d34399a6cd420049da2 /zlib/CMakeLists.txt
parentf2204146721cd2257ccc1f5954db680aa58b06ed (diff)
parente31f5611aadf37fb7436de255120cbc8bcbb4fb5 (diff)
downloadmariadb-git-c4c200749a200a7e89ecc6d09c3c41941e0ff50e.tar.gz
Merge dfischer@bk-internal.mysql.com:/home/bk/mysql-5.1-build
into pippilotta.erinye.com:/shared/home/df/mysql/build/mysql-5.1-build libmysql/CMakeLists.txt: merge fix
Diffstat (limited to 'zlib/CMakeLists.txt')
-rwxr-xr-xzlib/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/zlib/CMakeLists.txt b/zlib/CMakeLists.txt
index 3d176e59c88..43235b631f6 100755
--- a/zlib/CMakeLists.txt
+++ b/zlib/CMakeLists.txt
@@ -18,9 +18,13 @@
# Not directly and indirectly using any of the macros for creating and
# using the storage, pthread_key*(), {,my_}{set,get}_specific*() ....
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/zlib)
+
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG")
-ADD_LIBRARY(zlib adler32.c compress.c crc32.c crc32.h deflate.c deflate.h gzio.c infback.c inffast.c inffast.h
+SET(ZLIB_SOURCES adler32.c compress.c crc32.c crc32.h deflate.c deflate.h gzio.c infback.c inffast.c inffast.h
inffixed.h inflate.c inflate.h inftrees.c inftrees.h trees.c trees.h uncompr.c zconf.h zlib.h
zutil.c zutil.h)
-
+IF(NOT SOURCE_SUBLIBS)
+ ADD_LIBRARY(zlib ${ZLIB_SOURCES})
+ENDIF(NOT SOURCE_SUBLIBS)