summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index 369e02e4654..e57a1abcb0c 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -13,7 +13,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-noinst_SCRIPTS = Support/generate-text-files.pl
+noinst_SCRIPTS = generate-text-files.pl
EXTRA_DIST = $(noinst_SCRIPTS) manual.chm mysql.info INSTALL-BINARY
@@ -41,7 +41,7 @@ DISTCLEANFILES = $(TXT_FILES)
CLEAN_FILES: $(TXT_FILES)
touch $(TXT_FILES)
-GT = $(srcdir)/Support/generate-text-files.pl
+GT = $(srcdir)/generate-text-files.pl
../INSTALL-SOURCE: $(srcdir)/mysql.info $(GT)
perl -w $(GT) $(srcdir)/mysql.info "installing-source" "windows-source-build" > $@
@@ -58,5 +58,12 @@ INSTALL-BINARY: $(srcdir)/mysql.info $(GT)
../support-files/MacOSX/ReadMe.txt: $(srcdir)/mysql.info $(GT)
perl -w $(GT) $(srcdir)/mysql.info "mac-os-x-installation" "netware-installation" > $@
+# Include the Windows manual.chm in source .tar.gz only if available.
+# It is not in BitKeeper, but is downloaded from intranet by Bootstrap.
+dist-hook:
+ if [ -e $(srcdir)/manual.chm ] ; then \
+ cp -f $(srcdir)/manual.chm $(distdir); \
+ fi
+
# Don't update the files from bitkeeper
%::SCCS/s.%