summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index f9f5f38be6c..10201e4df63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,14 +23,22 @@ EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
@readline_topdir@ sql-common scripts \
- @thread_dirs@ pstack \
+ @pstack_dir@ \
@sql_union_dirs@ unittest storage plugin \
@sql_server@ @man_dirs@ tests \
netware @libmysqld_dirs@ \
mysql-test support-files sql-bench @tools_dirs@ \
win
-DIST_SUBDIRS = $(SUBDIRS) BUILD debian
+DIST_SUBDIRS = . include Docs zlib \
+ cmd-line-utils sql-common scripts \
+ pstack \
+ strings mysys dbug extra regex libmysql libmysql_r client unittest storage plugin \
+ vio sql man tests \
+ netware libmysqld \
+ mysql-test support-files sql-bench server-tools \
+ win \
+ BUILD debian
DISTCLEANFILES = ac_available_languages_fragment
@@ -45,7 +53,6 @@ bin-dist: all
# Create initial database files for Windows installations.
dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
- rm -f `find $(distdir) -type l -print`
mkdir -p $(distdir)/win
scripts/mysql_install_db --no-defaults --windows \
--basedir=$(top_builddir) \
@@ -146,8 +153,8 @@ test-bt:
cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=NIST+ps --force --suite=nist --ps-protocol ; \
fi
- -cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --force --comment=stress --suite=stress
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=stress --suite=stress
# Re-enable the "jp" suite when bug#28563 is fixed
# -cd mysql-test ; MTR_BUILD_THREAD=auto \