summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 44 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 92b8428e40e..9e9520c29d8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,8 @@ DIST_SUBDIRS = . include @docs_dirs@ zlib \
@thread_dirs@ pstack \
@sql_union_dirs@ scripts @man_dirs@ tests SSL\
BUILD netware os2 @libmysqld_dirs@ \
- @bench_dirs@ support-files @tools_dirs@ win
+ @bench_dirs@ support-files @tools_dirs@ win \
+ debian
# Run these targets before any others, also make part of clean target,
# to make sure we create new links after a clean.
@@ -112,7 +113,9 @@ tags:
.PHONY: init-db bin-dist \
test test-force test-full test-force-full test-force-mem \
test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
- test-ps test-ns
+ test-ps test-ns test-ext-funcs test-ext \
+ test-fast test-fast-cursor test-fast-view test-fast-prepare \
+ test-full-qa
# Target 'test' will run the regression test suite using the built server.
#
@@ -124,11 +127,11 @@ tags:
test-ps:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force) --ps-protocol
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ps-protocol
test-ns:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force)
+ @PERL@ ./mysql-test-run.pl $(force) $(mem)
test: test-ns test-ps
@@ -143,7 +146,17 @@ test-force-full:
#used by autopush.pl to run memory based tests
test-force-mem:
- $(MAKE) 'force=--force --mem' test
+ $(MAKE) force=--force mem=--mem test
+
+test-bt:
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=normal --report-features
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=ps --ps-protocol
+
+test-bt-debug:
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=debug --report-features
# Keep these for a while
test-pl: test
@@ -152,5 +165,31 @@ test-force-pl: test-force
test-force-pl-mem: test-force-mem
test-force-full-pl: test-force-full
+test-ext-funcs:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=funcs_1 ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=funcs_2
+
+test-ext: test-ext-funcs
+
+test-fast:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(subset) --force --skip-ndb --skip-innodb --skip-im --skip-rpl ; \
+ @PERL@ ./mysql-test-run.pl $(subset) --force --suite=funcs_1 --do-test=myisam
+
+test-fast-view:
+ $(MAKE) subset=--view-protocol test-fast
+
+test-fast-cursor:
+ $(MAKE) subset=--cursor-protocol test-fast
+
+test-fast-prepare:
+ $(MAKE) subset=--ps-protocol test-fast
+
+test-full-qa:
+ $(MAKE) force=--force test-pl \
+ test-ext test-fast-view \
+ test-fast-cursor
+
# Don't update the files from bitkeeper
%::SCCS/s.%