summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a575b3c365..bcffe546e7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,7 +118,7 @@ test-unit:
test-ps:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=statement
+ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=mixed
test-nr:
cd mysql-test ; \
@@ -130,6 +130,10 @@ test-pr:
test-ns:
cd mysql-test ; \
+ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=mixed
+
+test-binlog-statement:
+ cd mysql-test ; \
./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
test: test-unit test-ns test-pr