summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am169
1 files changed, 90 insertions, 79 deletions
diff --git a/Makefile.am b/Makefile.am
index c1bdbb22e8e..c968c50f6bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,74 +21,26 @@ AUTOMAKE_OPTIONS = foreign
EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
README COPYING EXCEPTIONS-CLIENT CMakeLists.txt
-SUBDIRS = . include @docs_dirs@ @zlib_dir@ @yassl_dir@ \
+SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
@readline_topdir@ sql-common scripts \
- @thread_dirs@ pstack \
- @sql_union_dirs@ @man_dirs@ tests \
+ @pstack_dir@ \
+ @sql_union_dirs@ unittest storage plugin \
+ @sql_server@ @man_dirs@ tests \
netware @libmysqld_dirs@ \
- @bench_dirs@ support-files @tools_dirs@
-
-DIST_SUBDIRS = . include @docs_dirs@ zlib \
- @readline_topdir@ sql-common \
- @thread_dirs@ pstack \
- @sql_union_dirs@ scripts @man_dirs@ tests SSL\
- BUILD netware os2 @libmysqld_dirs@ \
- @bench_dirs@ support-files @tools_dirs@ win
-
-# Run these targets before any others, also make part of clean target,
-# to make sure we create new links after a clean.
-BUILT_SOURCES = linked_client_sources linked_server_sources \
- @linked_client_targets@ \
- @linked_libmysqld_targets@ \
- linked_include_sources @linked_netware_sources@
-
-# The db.h file is a bit special, see note in "configure.in".
-# In the case we didn't compile with bdb, a dummy file is put
-# there, but will not be removed by the bdb make file becuase
-# it will never be called.
-CLEANFILES = $(BUILT_SOURCES) bdb/build_unix/db.h
+ mysql-test support-files sql-bench @tools_dirs@ \
+ win
+
+DIST_SUBDIRS = . include Docs zlib \
+ cmd-line-utils sql-common scripts \
+ pstack \
+ strings mysys dbug extra regex libmysql libmysql_r client unittest storage plugin \
+ vio sql man tests \
+ netware libmysqld \
+ mysql-test support-files sql-bench server-tools \
+ win \
+ BUILD
DISTCLEANFILES = ac_available_languages_fragment
-# Our current filtering of "sql_yacc.cc" in "sql/Makefile.am" creates
-# a problem, if a VPATH build and "sql_yacc.cc" was part of the source
-# distribution we end up with one "sql_yacc.cc" in the source tree,
-# and one in the build tree. This breaks "distcleancheck", until this
-# is sorted out we redefine the find that scans for files not removed
-
-distcleancheck_listfiles = find . -name sql_yacc.cc -o -type f -print
-
-linked_include_sources:
- cd include; $(MAKE) link_sources
- echo timestamp > linked_include_sources
-
-linked_client_sources: @linked_client_targets@
- cd client; $(MAKE) link_sources
- echo timestamp > linked_client_sources
-
-linked_libmysql_sources:
- cd libmysql; $(MAKE) link_sources
- echo timestamp > linked_libmysql_sources
-
-linked_libmysql_r_sources: linked_libmysql_sources
- cd libmysql_r; $(MAKE) link_sources
- echo timestamp > linked_libmysql_r_sources
-
-linked_libmysqld_sources:
- cd libmysqld; $(MAKE) link_sources
- echo timestamp > linked_libmysqld_sources
-
-linked_libmysqldex_sources:
- cd libmysqld/examples; $(MAKE) link_sources
- echo timestamp > linked_libmysqldex_sources
-
-linked_netware_sources:
- cd @netware_dir@; $(MAKE) link_sources
- echo timestamp > linked_netware_sources
-
-linked_server_sources:
- cd sql; $(MAKE) link_sources
- echo timestamp > linked_server_sources
-
# Create permission databases
init-db: all
$(top_builddir)/scripts/mysql_install_db
@@ -100,7 +52,6 @@ bin-dist: all
# Create initial database files for Windows installations.
dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
- rm -f `find $(distdir) -type l -print`
mkdir -p $(distdir)/win
scripts/mysql_install_db --no-defaults --windows \
--basedir=$(top_builddir) \
@@ -113,7 +64,9 @@ tags:
.PHONY: init-db bin-dist \
test test-force test-full test-force-full test-force-mem \
test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
- test-ps test-ns test-ext-funcs test-ext \
+ test-unit test-ps test-nr test-pr test-ns test-binlog-statement \
+ test-ext-funcs test-ext-rpl test-ext-partitions test-ext-jp \
+ test-ext-stress test-ext \
test-fast test-fast-cursor test-fast-view test-fast-prepare \
test-full-qa
@@ -125,18 +78,32 @@ tags:
# will then calculate the various port numbers it needs from this,
# making sure each user use different ports.
+test-unit:
+ cd unittest && $(MAKE) test
+
test-ps:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force) $(mem) --ps-protocol
+ @PERL@ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=mixed
+
+test-nr:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=row
+
+test-pr:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ps-protocol --mysqld=--binlog-format=row
test-ns:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force) $(mem)
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --mysqld=--binlog-format=mixed
+
+test-binlog-statement:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
-test: test-ns test-ps
+test: test-unit test-ns test-pr
-# To ease script-writing, although in 5.0 it is identical to 'test'
-test-full: test
+test-full: test test-nr test-ps
test-force:
$(MAKE) force=--force test
@@ -150,13 +117,33 @@ test-force-mem:
test-bt:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --force --comment=normal --report-features
+ @PERL@ ./mysql-test-run.pl --comment=normal --force --timer \
+ --skip-ndbcluster --report-features
-cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --force --comment=ps --ps-protocol
+ @PERL@ ./mysql-test-run.pl --comment=ps --force --timer \
+ --skip-ndbcluster --ps-protocol
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=normal+rowrepl --force --timer \
+ --skip-ndbcluster --mysqld=--binlog-format=row
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=ps+rowrepl+NDB --force --timer \
+ --ps-protocol --mysqld=--binlog-format=row
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=NDB --force --timer \
+ --with-ndbcluster-only
+ -if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
+ cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
+ --embedded-server --skip-rpl --skip-ndbcluster ; \
+ fi
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=funcs1_ps --ps-protocol --suite=funcs_1
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=funcs2 --suite=funcs_2
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=rpl --suite=rpl
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=partitions --suite=parts
-if [ -d mysql-test/suite/nist ] ; then \
cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=NIST+normal --force --suite=nist ; \
@@ -165,10 +152,17 @@ test-bt:
cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=NIST+ps --force --suite=nist --ps-protocol ; \
fi
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=stress --suite=stress
+
+# Re-enable the "jp" suite when bug#28563 is fixed
+# -cd mysql-test ; MTR_BUILD_THREAD=auto \
+# @PERL@ ./mysql-test-run.pl --force --comment=jp --suite=jp
test-bt-debug:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --force --comment=debug --report-features
+ @PERL@ ./mysql-test-run.pl --comment=debug --force --timer \
+ --skip-ndbcluster --skip-rpl --report-features
# Keep these for a while
test-pl: test
@@ -182,12 +176,29 @@ test-ext-funcs:
@PERL@ ./mysql-test-run.pl --force --suite=funcs_1 ; \
@PERL@ ./mysql-test-run.pl --force --suite=funcs_2
-test-ext: test-ext-funcs
+test-ext-rpl:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=rpl
+
+test-ext-partitions:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=parts
+
+test-ext-jp:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=jp
+
+test-ext-stress:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --big-test --suite=stress
+
+test-ext: test-ext-funcs test-ext-rpl test-ext-partitions test-ext-jp test-ext-stress
test-fast:
cd mysql-test ; \
@PERL@ ./mysql-test-run.pl $(subset) --force --skip-ndb --skip-innodb --skip-im --skip-rpl ; \
- @PERL@ ./mysql-test-run.pl $(subset) --force --suite=funcs_1 --do-test=myisam
+ @PERL@ ./mysql-test-run.pl $(subset) --force --suite=funcs_1 --do-test=myisam ; \
+ @PERL@ ./mysql-test-run.pl $(subset) --force --suite=stress --do-test=ddl_myisam
test-fast-view:
$(MAKE) subset=--view-protocol test-fast
@@ -199,9 +210,9 @@ test-fast-prepare:
$(MAKE) subset=--ps-protocol test-fast
test-full-qa:
- $(MAKE) force=--force test-pl \
- test-ext test-fast-view \
- test-fast-cursor
+ $(MAKE) force=--force test-pr \
+ test-binlog-statement test-ext test-fast-view \
+ test-fast-cursor test-unit
# Don't update the files from bitkeeper
%::SCCS/s.%