summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1aa6c48755f..d742539da26 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,6 +147,16 @@ test-force-full:
test-force-mem:
$(MAKE) force=--force mem=--mem test
+test-bt:
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=normal --report-features
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=ps --ps-protocol
+
+test-bt-debug:
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=debug --report-features
+
# Keep these for a while
test-pl: test
test-full-pl: test-full