summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 70ed8fa7bfe..f7a9ffa7c2a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,20 +20,20 @@ AUTOMAKE_OPTIONS = foreign
# These are built from source in the Docs directory
EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
- README COPYING EXCEPTIONS-CLIENT
-SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
+ README COPYING EXCEPTIONS-CLIENT CMakeLists.txt
+SUBDIRS = . include @docs_dirs@ @zlib_dir@ @yassl_dir@ \
@readline_topdir@ sql-common \
@thread_dirs@ pstack \
@sql_union_dirs@ scripts @man_dirs@ tests \
netware @libmysqld_dirs@ \
- @bench_dirs@ support-files @fs_dirs@ @tools_dirs@
+ @bench_dirs@ support-files @tools_dirs@
DIST_SUBDIRS = . include @docs_dirs@ zlib \
@readline_topdir@ sql-common \
@thread_dirs@ pstack \
@sql_union_dirs@ scripts @man_dirs@ tests SSL\
BUILD netware os2 @libmysqld_dirs@ \
- @bench_dirs@ support-files @fs_dirs@ @tools_dirs@
+ @bench_dirs@ support-files @tools_dirs@ win
# Run these targets before any others, also make part of clean target,
# to make sure we create new links after a clean.
@@ -49,6 +49,14 @@ BUILT_SOURCES = linked_client_sources linked_server_sources \
CLEANFILES = $(BUILT_SOURCES) bdb/build_unix/db.h
DISTCLEANFILES = ac_available_languages_fragment
+# Our current filtering of "sql_yacc.cc" in "sql/Makefile.am" creates
+# a problem, if a VPATH build and "sql_yacc.cc" was part of the source
+# distribution we end up with one "sql_yacc.cc" in the source tree,
+# and one in the build tree. This breaks "distcleancheck", until this
+# is sorted out we redefine the find that scans for files not removed
+
+distcleancheck_listfiles = find . -name sql_yacc.cc -o -type f -print
+
linked_include_sources:
cd include; $(MAKE) link_sources
echo timestamp > linked_include_sources
@@ -89,9 +97,15 @@ bin-dist: all
$(top_builddir)/scripts/make_binary_distribution @MAKE_BINARY_DISTRIBUTION_OPTIONS@
# Remove BK's "SCCS" subdirectories from source distribution
+# Create initial database files for Windows installations.
dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
rm -f `find $(distdir) -type l -print`
+ mkdir -p $(distdir)/win
+ scripts/mysql_install_db --no-defaults --windows \
+ --basedir=$(top_builddir) \
+ --datadir=$(distdir)/win/data \
+ --srcdir=$(top_srcdir)
tags:
support-files/build-tags
@@ -119,7 +133,7 @@ test-ns:
test: test-ns test-ps
-# To ease script-writing, although in 4.1 it is identical to 'test'
+# To ease script-writing, although in 5.0 it is identical to 'test'
test-full: test
test-force: