summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 747b27e9aa0..c2993c5a0d5 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -36,6 +36,10 @@ noinst_HEADERS = sql_string.h completion_hash.h my_readline.h \
EXTRA_DIST = get_password.c CMakeLists.txt
+BUILT_SOURCES = link_sources
+
+CLEANFILES = $(BUILT_SOURCES)
+
bin_PROGRAMS = mysql \
mysqladmin \
mysqlbinlog \
@@ -108,6 +112,7 @@ link_sources:
done; \
rm -f $(srcdir)/my_user.c; \
@LN_CP_F@ $(top_srcdir)/sql-common/my_user.c my_user.c;
+ echo timestamp > link_sources;
# Don't update the files from bitkeeper
%::SCCS/s.%