summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 61877c6b885..e4cf1d09dc5 100644
--- a/configure.in
+++ b/configure.in
@@ -934,6 +934,16 @@ case $SYSTEM_TYPE in
echo "Using --with-named-thread=-lpthread"
with_named_thread="-lpthread"
fi
+ # Fixes for HPUX 11.0 compiler
+ if test "$ac_cv_prog_gcc" = "no"
+ then
+ CFLAGS="$CFLAGS +DD64 -DHAVE_BROKEN_INLINE"
+ CXXFLAGS="$CXXFLAGS +DD64"
+ if "$with_debug" = "no"
+ then
+ CXXFLAGS="$CXXFLAGS +O2"
+ fi
+ fi
;;
*rhapsody*)
if test "$ac_cv_prog_gcc" = "yes"