summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fdec3bb3a6c..41ca923c4d6 100644
--- a/configure.in
+++ b/configure.in
@@ -718,6 +718,20 @@ else
AC_MSG_RESULT([no])
fi
+# Add query profiler
+AC_ARG_ENABLE(profiling,
+ AS_HELP_STRING([--disable-profiling], [Build a version without query profiling code]),
+ [ ENABLED_PROFILING=$enableval ],
+ [ ENABLED_PROFILING=yes ])
+
+if test "$ENABLED_PROFILING" = "yes"
+then
+ AC_DEFINE([ENABLED_PROFILING], [1],
+ [If SHOW PROFILE should be enabled])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
# Use this to set the place used for unix socket used to local communication.
AC_ARG_WITH(unix-socket-path,
@@ -1171,7 +1185,6 @@ case $SYSTEM_TYPE in
fi
;;
*darwin*)
- AC_DEFINE([DEFAULT_SKIP_THREAD_PRIORITY], [1], [default to skip thread priority])
if test "$ac_cv_prog_gcc" = "yes"
then
FLAGS="-D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT"