summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in82
1 files changed, 44 insertions, 38 deletions
diff --git a/configure.in b/configure.in
index 0e4ea0422c3..7a279cb0b39 100644
--- a/configure.in
+++ b/configure.in
@@ -752,6 +752,7 @@ else
AC_MSG_RESULT([no])
fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked
@@ -870,6 +871,9 @@ AC_SUBST(WRAPLIBS)
if test "$TARGET_LINUX" = "true"; then
AC_MSG_CHECKING([for atomic operations])
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+
atom_ops=
AC_TRY_RUN([
#include <asm/atomic.h>
@@ -905,6 +909,8 @@ int main()
if test -z "$atom_ops"; then atom_ops="no"; fi
AC_MSG_RESULT($atom_ops)
+ AC_LANG_RESTORE
+
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],
@@ -1704,6 +1710,21 @@ else
CXXFLAGS="$OPTIMIZE_CXXFLAGS -DDBUG_OFF $CXXFLAGS"
fi
+# If we should allow error injection tests
+AC_ARG_WITH(error-inject,
+ [ --with-error-inject Enable error injection in MySQL Server],
+ [ with_error_inject=$withval ],
+ [ with_error_inject=no ])
+
+if test $with_debug != "no"
+then
+ if test "$with_error_inject" = "yes"
+ then
+ AC_DEFINE([ERROR_INJECT_SUPPORT], [1],
+ [Enable error injection in MySQL Server])
+ fi
+fi
+
AC_ARG_WITH([fast-mutexes],
AC_HELP_STRING([--with-fast-mutexes],
[Compile with fast mutexes (default is disabled)]),
@@ -2314,23 +2335,7 @@ then
[Access checks in embedded library])
fi
-AC_ARG_WITH(extra-tools,
- [ --without-extra-tools Skip building utilites in the tools directory.],
- [with_tools=$withval],
- [with_tools=yes]
-)
-
tools_dirs=""
-if test "$with_tools" = "yes"
-then
- if test "$THREAD_SAFE_CLIENT" = "no"
- then
- AC_MSG_WARN([extra-tools disabled because --enable-thread-safe-client wasn't used])
- else
- tools_dirs="tools"
- AC_CONFIG_FILES(tools/Makefile)
- fi
-fi
AC_ARG_WITH([mysqlmanager],
AC_HELP_STRING([--with-mysqlmanager], [Build the mysqlmanager binary: yes/no (default: build if server is built.)]),
@@ -2400,22 +2405,6 @@ fi
AC_SUBST(man_dirs)
AC_SUBST(man1_files)
-# Shall we build the bench code?
-AC_ARG_WITH(bench,
- [ --without-bench Skip building of the benchmark suite.],
- [with_bench=$withval],
- [with_bench=yes]
-)
-
-if test "$with_bench" = "yes"
-then
- bench_dirs="sql-bench"
-else
- bench_dirs=""
-fi
-bench_dirs="$bench_dirs mysql-test"
-AC_SUBST(bench_dirs)
-
# Don't build readline, i have it already
AC_ARG_WITH(readline,
[ --without-readline Use system readline instead of bundled copy.],
@@ -2429,6 +2418,12 @@ AC_ARG_WITH(libedit,
[ with_libedit=undefined ]
)
+if test "$with_readline/$with_libedit" = "undefined/undefined" -a ! -e "$srcdir/cmd-line-utils"
+then
+ with_readline=no
+ with_libedit=no
+fi
+
#
# We support next variants of compilation:
# --with-readline
@@ -2504,6 +2499,16 @@ else
versions of libedit or readline])
fi
fi
+#
+# if either readline or libedit is enabled - generate Makefile's for both
+# (to make sure both are included in 'make dist')
+#
+if test -n "$readline_basedir"
+then
+ AC_CONFIG_FILES(cmd-line-utils/Makefile dnl
+ cmd-line-utils/libedit/Makefile dnl
+ cmd-line-utils/readline/Makefile)
+fi
fi
AC_SUBST(readline_dir)
@@ -2512,6 +2517,7 @@ AC_SUBST(readline_basedir)
AC_SUBST(readline_link)
AC_SUBST(readline_h_ln_cmd)
+
# If we have threads generate some library functions and test programs
sql_server_dirs=
sql_server=
@@ -2567,6 +2573,7 @@ then
AC_SUBST(THREAD_LOBJECTS)
server_scripts="mysqld_safe mysql_install_db"
sql_server_dirs="strings mysys dbug extra regex"
+
sql_server="$sql_server vio sql"
fi
@@ -2626,6 +2633,9 @@ AC_SUBST(MAKE_BINARY_DISTRIBUTION_OPTIONS)
# Output results
AC_CONFIG_FILES(Makefile extra/Makefile mysys/Makefile dnl
+ unittest/Makefile dnl
+ unittest/mytap/Makefile unittest/mytap/t/Makefile dnl
+ unittest/mysys/Makefile unittest/examples/Makefile dnl
strings/Makefile regex/Makefile dnl
storage/Makefile dnl
storage/archive/Makefile storage/bdb/Makefile storage/blackhole/Makefile dnl
@@ -2634,18 +2644,14 @@ AC_CONFIG_FILES(Makefile extra/Makefile mysys/Makefile dnl
man/Makefile BUILD/Makefile vio/Makefile dnl
libmysql/Makefile client/Makefile dnl
pstack/Makefile pstack/aout/Makefile sql/Makefile sql/share/Makefile dnl
- sql/sql_builtin.cc sql-common/Makefile SSL/Makefile dnl
+ sql/sql_builtin.cc sql-common/Makefile dnl
dbug/Makefile scripts/Makefile dnl
- include/Makefile sql-bench/Makefile dnl
+ include/Makefile dnl
server-tools/Makefile server-tools/instance-manager/Makefile dnl
tests/Makefile Docs/Makefile support-files/Makefile dnl
support-files/MacOSX/Makefile mysql-test/Makefile dnl
mysql-test/ndb/Makefile netware/Makefile dnl
include/mysql_version.h dnl
- cmd-line-utils/Makefile dnl
- cmd-line-utils/libedit/Makefile dnl
- zlib/Makefile dnl
- cmd-line-utils/readline/Makefile dnl
plugin/Makefile dnl
plugin/fulltext/Makefile dnl
win/Makefile)