summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in42
1 files changed, 28 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 2ba832d4e2b..e8e2bdb7951 100644
--- a/configure.in
+++ b/configure.in
@@ -1544,16 +1544,35 @@ else
fi
#---END:
-# Check for dlopen, needed for user definable functions
-# This must be checked after threads on AIX
-# We only need this for mysqld, not for the clients.
+# dlopen, dlerror
+case $with_mysqld_ldflags in
+
+ *-all-static*)
+ # No need to check for dlopen when mysqld is linked with
+ # -all-static as it won't be able to load any functions.
+
+ ;;
+
+ *)
+ # Check for dlopen, needed for user definable functions
+ # This must be checked after threads on AIX
+ # We only need this for mysqld, not for the clients.
+
+ my_save_LIBS="$LIBS"
+ LIBS=""
+ AC_CHECK_LIB(dl,dlopen)
+ LIBDL=$LIBS
+ LIBS="$my_save_LIBS"
+ AC_SUBST(LIBDL)
+
+ my_save_LIBS="$LIBS"
+ LIBS="$LIBS $LIBDL"
+ AC_CHECK_FUNCS(dlopen dlerror)
+ LIBS="$my_save_LIBS"
+
+ ;;
+esac
-my_save_LIBS="$LIBS"
-LIBS=""
-AC_CHECK_LIB(dl,dlopen)
-LIBDL=$LIBS
-LIBS="$my_save_LIBS"
-AC_SUBST(LIBDL)
# System characteristics
case $SYSTEM_TYPE in
@@ -1922,11 +1941,6 @@ then
fi]
)
-my_save_LIBS="$LIBS"
-LIBS="$LIBS $LIBDL"
-AC_CHECK_FUNCS(dlopen dlerror)
-LIBS="$my_save_LIBS"
-
# Check definition of gethostbyaddr_r (glibc2 defines this with 8 arguments)
ac_save_CXXFLAGS="$CXXFLAGS"
AC_CACHE_CHECK([style of gethost* routines], mysql_cv_gethost_style,