summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 8c6249319fd..5e36c1446de 100644
--- a/configure.in
+++ b/configure.in
@@ -602,17 +602,22 @@ AC_ARG_WITH(mysqld-user,
)
AC_SUBST(MYSQLD_USER)
-# compile with strings functions in assembler
+# If we should allove LOAD DATA LOCAL
+AC_MSG_CHECKING(if we should should enable LOAD DATA LOCAL by default)
AC_ARG_ENABLE(local-infile,
[ --enable-local-infile
If LOAD DATA LOCAL INFILE is enabled by default.],
- [
- ENABLED_LOCAL_INFILE=$enablewal
- AC_DEFINE(ENABLED_LOCAL_INFILE)
- ],
+ [ ENABLED_LOCAL_INFILE=$enableval ],
[ ENABLED_LOCAL_INFILE=no ]
)
-
+if test "$ENABLED_LOCAL_INFILE" = "yes"
+then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([ENABLED_LOCAL_INFILE])
+else
+ AC_MSG_RESULT([no])
+fi
+
# Use Paul Eggerts macros from GNU tar to check for large file support.
MYSQL_SYS_LARGEFILE