summaryrefslogtreecommitdiff
path: root/dbug/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dbug/Makefile.am')
-rw-r--r--dbug/Makefile.am67
1 files changed, 0 insertions, 67 deletions
diff --git a/dbug/Makefile.am b/dbug/Makefile.am
deleted file mode 100644
index 499ab1a35e6..00000000000
--- a/dbug/Makefile.am
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright (C) 2000, 2002, 2004-2006 MySQL AB
-#
-# This library is free software; you can redistribute it and/or
-# modify it under the terms of the GNU Library General Public
-# License as published by the Free Software Foundation; version 2
-# of the License.
-#
-# This library is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-#
-# You should have received a copy of the GNU Library General Public
-# License along with this library; if not, write to the Free
-# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
-# MA 02111-1307, USA
-
-INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
-LDADD = libdbug.a ../mysys/libmysys.a ../strings/libmystrings.a
-pkglib_LIBRARIES = libdbug.a
-noinst_HEADERS = dbug_long.h
-libdbug_a_SOURCES = dbug.c
-EXTRA_DIST = CMakeLists.txt example1.c example2.c example3.c \
- user.r monty.doc dbug_add_tags.pl \
- my_main.c main.c factorial.c dbug_analyze.c \
- CMakeLists.txt tests.c tests-t.pl
-NROFF_INC = example1.r example2.r example3.r main.r \
- factorial.r output1.r output2.r output3.r \
- output4.r output5.r
-CLEANFILES = $(NROFF_INC) user.t user.ps tests-t
-
-
-# Must be linked with libs that are not compiled yet
-noinst_PROGRAMS = factorial dbug_analyze tests
-factorial_SOURCES = my_main.c factorial.c
-tests_SOURCES = tests.c
-dbug_analyze_SOURCES = dbug_analyze.c
-
-all: user.t user.ps tests-t
-
-user.t: user.r $(NROFF_INC)
- -nroff -mm user.r > $@
-
-user.ps: user.r $(NROFF_INC)
- -groff -mm user.r > $@
-
-output1.r: factorial
- ./factorial 1 2 3 4 5 | cat > $@
-
-output2.r: factorial
- ./factorial -\#t:o 2 3 | cat >$@
-
-output3.r: factorial
- ./factorial -\#d:t:o 3 | cat >$@
-
-output4.r: factorial
- ./factorial -\#d,result:o 4 | cat >$@
-
-output5.r: factorial
- ./factorial -\#d:f,factorial:F:L:o 3 | cat >$@
-.c.r:
- @RM@ -f $@
- @SED@ -e 's!\\!\\\\!g' $< > $@
-
-# a hack to have executable in builddir, not in srcdir
-tests-t: tests-t.pl
- cp -f $(srcdir)/tests-t.pl ./tests-t